[USRP-users] uhd_usrp message return and Comms issues

Derek Kozel derek.kozel at ettus.com
Tue Oct 3 08:37:05 EDT 2017


Hi Mark,

I'm glad to hear you were able to update to 3.9. Retuning the UBX takes
approximately 500 usec. This varies based on how far the internal VCO needs
to tune and if there is a band crossing.

A dwell time of 5 seconds (5,000 msec) should be four orders of magnitude
more than is needed to get good data. There is no included utility to
measure the retune time. A quick test to do is to externally generate tones
at two frequencies and, while receiving and saving the samples, tune from
one to the other. The retune time can be seen as the duration between the
loss of the first signal and the stable reception of the second one.

How are you doing your acquisitions? If you look at the TwinRX fast
frequency hopping example it implements an approach where timed commands
are used to tune the channel and another to acquire a specific number of
samples. The commands are scheduled such that there is an appropriate delay
between acquisitions for the synthesizers to settle.
https://github.com/EttusResearch/uhd/blob/122bfae1a09cca732040cbdc5d7d20e68d0d755d/host/examples/twinrx_freq_hopping.cpp

Regards,
Derek

On Tue, Oct 3, 2017 at 12:56 PM, Mark Koenig <
mark.koenig at iubelttechnologies.com> wrote:

> Hi Derek,
>
>
>
> I have recently upgraded to UHD rev 003.009.000 and have everything up and
> running on Centos 6.5.  I am currently working on migrating to Centos 7.2
> and hope to be there in the next couple of days.  I am still seeing the
> retuning issues with the x310, unlike with the N210.
>
>
>
> What would be a good way of calculating how long the retunes are taking?
> Is there a built in UHD utility to help with that?  I know the retunes are
> taking longer because in an application I use I had to increase the dwell
> time from 5,000 msec to 30,000 msec to avoid any frequencies being skipped
> in the retune.
>
>
>
> I am using UBX40 daughtercards and my X310 revision is 4.
>
>
>
> Thanks
>
>
>
> Mark
>
>
>
> *From: *Derek Kozel <derek.kozel at ettus.com>
> *Date: *Tuesday, October 3, 2017 at 7:44 AM
> *To: *Mark Koenig <mark.koenig at iubelttechnologies.com>
> *Cc: *"usrp-users at lists.ettus.com" <usrp-users at lists.ettus.com>
> *Subject: *Re: [USRP-users] uhd_usrp message return and Comms issues
>
>
>
> Hello Mark,
>
> It has been some time since I have looked at the probe routine in the 3.8
> version of UHD, but it sounds like the discovery packets are having routing
> problems. Do you have an N210, N200, or USRP2 anywhere on the network?
>
>
> We can probably give some assistance to discovering the root cause of
> those messages, but it sounds like your real issue is that the retunes are
> taking longer than you expect. How long are they taking? How are you
> measuring the retune time? What daughtercard are you using?
>
> We usually find that if you are running Centos and an older version of UHD
> means that updating is not possible or prohibitively difficult. It does
> bear saying that the X310 and daughtercard code bases have advanced over
> the past two years. The UHD 3.9 branch provides a nice middle ground where
> you can get access to many of these updates without large architectural
> changes.
>
> Regards,
>
> Derek
>
>
>
> On Mon, Sep 25, 2017 at 4:09 PM, Mark Koenig via USRP-users <
> usrp-users at lists.ettus.com> wrote:
>
> When I run the “uhd_usrp_probe” command I receive an interesting message
> prior to getting all of the information returned.  It is listed below.  I
> am having communication issues with the USRP X310 when changing
> frequencies, as it is taking much longer to retask the X310 than I would
> assume and therefor during my scan some frequencies are being missed.  I am
> using the 10gig bit Ethernet port, with a Chelsio card on a server running
> CentOS 6.5 with UHD rev 003.008.004.
>
>
>
> Any suggestions would be much appreciated.
>
>
>
> Thanks
>
>
>
> UHD  Error:
>
>                 X300 Network discovery error send_to:  Network is
> unreachable
>
>
>
> UHD  Error:
>
>                 X300 Network discovery error send_to:  Network is
> unreachable
>
>
>
> UHD  Error:
>
>                 USRP2 Network discovery error send_to:  Network is
> unreachable
>
>
>
> UHD  Error:
>
>                 USRP2 Network discovery error send_to:  Network is
> unreachable
>
> -- X300 initiallization sequence…
>
>
>
> Then the rest of the output is the usrp and daughtercard information,
> which is all correct.
>
>
>
>
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171003/97ce83c4/attachment-0002.html>


More information about the USRP-users mailing list