[USRP-users] uhd_usrp message return and Comms issues

Derek Kozel derek.kozel at ettus.com
Tue Oct 3 07:44:15 EDT 2017


Hello Mark,

It has been some time since I have looked at the probe routine in the 3.8
version of UHD, but it sounds like the discovery packets are having routing
problems. Do you have an N210, N200, or USRP2 anywhere on the network?

We can probably give some assistance to discovering the root cause of those
messages, but it sounds like your real issue is that the retunes are taking
longer than you expect. How long are they taking? How are you measuring the
retune time? What daughtercard are you using?

We usually find that if you are running Centos and an older version of UHD
means that updating is not possible or prohibitively difficult. It does
bear saying that the X310 and daughtercard code bases have advanced over
the past two years. The UHD 3.9 branch provides a nice middle ground where
you can get access to many of these updates without large architectural
changes.

Regards,
Derek

On Mon, Sep 25, 2017 at 4:09 PM, Mark Koenig via USRP-users <
usrp-users at lists.ettus.com> wrote:

> When I run the “uhd_usrp_probe” command I receive an interesting message
> prior to getting all of the information returned.  It is listed below.  I
> am having communication issues with the USRP X310 when changing
> frequencies, as it is taking much longer to retask the X310 than I would
> assume and therefor during my scan some frequencies are being missed.  I am
> using the 10gig bit Ethernet port, with a Chelsio card on a server running
> CentOS 6.5 with UHD rev 003.008.004.
>
>
>
> Any suggestions would be much appreciated.
>
>
>
> Thanks
>
>
>
> UHD  Error:
>
>                 X300 Network discovery error send_to:  Network is
> unreachable
>
>
>
> UHD  Error:
>
>                 X300 Network discovery error send_to:  Network is
> unreachable
>
>
>
> UHD  Error:
>
>                 USRP2 Network discovery error send_to:  Network is
> unreachable
>
>
>
> UHD  Error:
>
>                 USRP2 Network discovery error send_to:  Network is
> unreachable
>
> -- X300 initiallization sequence…
>
>
>
> Then the rest of the output is the usrp and daughtercard information,
> which is all correct.
>
>
>
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171003/bf6d3a9f/attachment-0002.html>


More information about the USRP-users mailing list