[USRP-users] How update CMake version in the software development kit (SDR)?

Philip Balister philip at balister.org
Mon Oct 2 08:57:02 EDT 2017


On 10/02/2017 02:57 AM, Torbjörn Olsson via USRP-users wrote:
> Hello,
> 
> I am trying to put GR-Inspector on my Ettus Research E312 (an embedded system). But when running cmake in the installation process I get:
> olt at aes:~/e300/src/gr-inspector/build$ cmake ..
> CMake Error at CMakeLists.txt:23 (cmake_minimum_required):
>  CMake 3.1 or higher is required.  You are running version 2.8.12.2

Try this image and sdk:

http://files.ettus.com/e3xx_images/beta/jethro-test/

The manifest shows: nativesdk-cmake x86_64-nativesdk 3.3.1-r0

Philip

> 
> 
> -- Configuring incomplete, errors occurred!
> olt at aes:~/e300/src/gr-inspector/build$
> It seems like the SDK used to cross compile for the E312 uses an older version of CMake than required by GR-Inspector. Has anyone experienced the same issue (and found a solution?). 
> 
> Grateful for any help!
> 
> Regards
> 
> Torbjörn 
> (embedded software and SDR newbie)
> 
> 
> 
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
> 




More information about the USRP-users mailing list