[USRP-users] underrun problem in GPS record and replay system with USRP/WBX

Derek Kozel derek.kozel at ettus.com
Mon Nov 27 10:42:14 EST 2017


Hello Fabrizio,

Have you tried running the benchmark_rate example included with UHD? That
can test if there is any issue sending data at that rate to the USRP.
uhd_siggen is also a good test as it uses GNU Radio so can check that the
rate continues to work from within GNU Radio.

If both of those work then more information would be needed about your GNU
Radio flowgraph. Is it only a file source into a USRP sink?

Regards,
Derek

On Mon, Nov 27, 2017 at 3:19 PM, Fabrizio Turin via USRP-users <
usrp-users at lists.ettus.com> wrote:

> Hi all
> for a research project I'm trying to record and replay few seconds of GPS
> signal. The recording part has been done correctly, a 40 seconds GPS
> acquisition has been tested against a GPS-SDR receiver obtaining a correct
> position fix. Now I'd like to transmit the recorded signal through RF cable
> and see if a commercial GPS receiver is able to get the position fix as
> well. The problem is that, as soon as I start the simple flow graph in GNU
> radio I get the "U" underrun warning (side note: PC became un-responding
> too) and it seems I'm not transmitting at all.
> Here's the complete description of the problem:
>
> Front-end: USRP N210 with WBX
>
> Recorded file:
>
> data type: complex float32
> centre freq: GPS L1
> sampling rate: 10 MHz
> acquisition length: 40 seconds
> recorded file size: 3.2 GB
>
> Host PC:
>
> OS: Windows 10 Pro (64bit)
> CPU: Intel Core i7-7820HQ
> RAM: 32 GB
> HD: Toshiba THNSNK512GCS8 (545 MB/s write speed)
> network adapter: gigabit capable
>
> USRP Sink configuration:
>
> sampling rate: 10 MHz
> input type: complex float32
> wire format: automatic
> centre freq: GPS L1
> Ch0:Antenna TX/RX
> (everything else as default)
>
> From the numbers I wouldn't say that the bottleneck is the HD (in any case
> I've already tried loading the recorded file from a RAMdisk with the same
> problems...) or the network speed.
> Any idea on what I'm doing wrong and how to get rid of the underrun
> warning?
> Thanks in advance
>
> Fabrizio
>
>
>
>
> ------------------------------------------------------------
> --------------------------
>
>
>
> The information contained in this e-mail is intended only for the
>
> individual or entity to whom it is addressed. Its contents (including
>
> any attachments) are confidential and privileged: if you are not an
>
> intended recipient you must not use, disclose, disseminate, copy or
>
> print its contents. If you have received this email by mistake please
>
> notify us by emailing the sender, and then delete and/or destroy the
>
> e-mail and any copies from your system
>
>
>
> ------------------------------------------------------------
> --------------------------
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171127/e3ded267/attachment-0002.html>


More information about the USRP-users mailing list