[USRP-users] Problem burning image to SD card for E312

Mann, John - 0662 - MITLL mannj at ll.mit.edu
Thu Nov 16 17:24:41 EST 2017


I tried issuing a sync command after the dd command - no help.

I also tried using bmaptool to burn the image.  It still doesn’t work.  And it still took around 10 minutes - no faster than dd.

Both commands finish without any error messages.

The image file's md5 checksum is correct, so the image did not get corrupted during the download.

I have even tried 2 different SD cards.

I'm running out of ideas... should I try a different host computer?  Any way to do this from Windows 7 or Windows 10?

-----Original Message-----
From: Philip Balister [mailto:philip at balister.org] 
Sent: Thursday, November 16, 2017 4:43 PM
To: Anon Lister <listeranon at gmail.com>
Cc: Mann, John - 0662 - MITLL <mannj at ll.mit.edu>; usrp-users <usrp-users at lists.ettus.com>
Subject: Re: [USRP-users] Problem burning image to SD card for E312

On 11/16/2017 04:37 PM, Anon Lister wrote:
> Make sure to run sync after to dd.

Interesting, I thought dd would run below the buffer cache layer.

> 
> Also curious as to reason for the recommendation against dd?
> 

bmaptool is faster. bmaptool also checks to see if the device has a mounted file system, so prevent you form overwriting something like /dev/sda. Basically, safer and faster.

Philip


> On Nov 16, 2017 12:35 PM, "Philip Balister via USRP-users" < 
> usrp-users at lists.ettus.com> wrote:
> 
>> Try bmaptool. dd is a bad idea, yeah I killed my hard drive once.
>>
>> https://wiki.gnuradio.org/index.php/Copy_an_image_file_to_the_SD_card
>>
>> The might even be package with Ubuntu. After writing, re-insert the 
>> card in the writer and see if it mounts the partitions.
>>
>> Philip
>>
>> On 11/16/2017 10:54 AM, Mann, John - 0662 - MITLL via USRP-users wrote:
>>> Running Ubuntu 16 on my host computer...
>>>
>>> I downloaded the image from:
>>>
>>> http://files.ettus.com/e3xx_images/e3xx-release-4/ettus-
>> e3xx-sg3/http://files.ettus.com/e3xx_images/e3xx-release-
>> 4/ettus-e3xx-sg3/sdimage-gnuradio-dev.direct.xz
>>>
>>> Then I decompressed the xz file using xzdec:
>>>
>>> xzdec sdimage-gnuradio-dev.direct.xz >> sdimage-gnuradio-dev.direct
>>>
>>> And burned the sd image using the dd command:
>>>
>>> sudo dd if=sdimage-gnuradio-dev.direct of=/dev/sdb1 bs=1M
>>>
>>> The dd command apparently finishes without error after about 10 
>>> minutes,
>> and I can see flashing lights on the SD card USB adapter, so I'm 
>> pretty sure it is getting written to the correct place.
>>>
>>> But the card does not work in the E312.  When I turn it on, the 4 
>>> LEDs
>> next to the Tx/Rx ports light up, but there is no activity on the 
>> console window.  I have another SD card that boots up fine, so I know 
>> the E312 is fine.  There is clearly something wrong with the SD card.  
>> When I plug the old working card into my Ubuntu host machine, I can 
>> actually see the files on the card.  When I plug the newly burned 
>> card back into the Ubuntu machine, I see nothing.
>>>
>>> Any idea what I am doing wrong?
>>>
>>> John Mann
>>> MIT Lincoln Laboratory
>>>
>>> _______________________________________________
>>> USRP-users mailing list
>>> USRP-users at lists.ettus.com
>>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>>
>>
>> _______________________________________________
>> USRP-users mailing list
>> USRP-users at lists.ettus.com
>> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>
> 


More information about the USRP-users mailing list