[USRP-users] Problem burning image to SD card for E312

Philip Balister philip at balister.org
Thu Nov 16 12:34:41 EST 2017


Try bmaptool. dd is a bad idea, yeah I killed my hard drive once.

https://wiki.gnuradio.org/index.php/Copy_an_image_file_to_the_SD_card

The might even be package with Ubuntu. After writing, re-insert the card
in the writer and see if it mounts the partitions.

Philip

On 11/16/2017 10:54 AM, Mann, John - 0662 - MITLL via USRP-users wrote:
> Running Ubuntu 16 on my host computer...
> 
> I downloaded the image from:
> 
> http://files.ettus.com/e3xx_images/e3xx-release-4/ettus-e3xx-sg3/http://files.ettus.com/e3xx_images/e3xx-release-4/ettus-e3xx-sg3/sdimage-gnuradio-dev.direct.xz 
> 
> Then I decompressed the xz file using xzdec:
> 
> xzdec sdimage-gnuradio-dev.direct.xz >> sdimage-gnuradio-dev.direct
> 
> And burned the sd image using the dd command:
> 
> sudo dd if=sdimage-gnuradio-dev.direct of=/dev/sdb1 bs=1M
> 
> The dd command apparently finishes without error after about 10 minutes, and I can see flashing lights on the SD card USB adapter, so I'm pretty sure it is getting written to the correct place.
> 
> But the card does not work in the E312.  When I turn it on, the 4 LEDs  next to the Tx/Rx ports light up, but there is no activity on the console window.  I have another SD card that boots up fine, so I know the E312 is fine.  There is clearly something wrong with the SD card.  When I plug the old working card into my Ubuntu host machine, I can actually see the files on the card.  When I plug the newly burned card back into the Ubuntu machine, I see nothing.
> 
> Any idea what I am doing wrong?
> 
> John Mann
> MIT Lincoln Laboratory
> 
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
> 




More information about the USRP-users mailing list