[USRP-users] Setting Up USRP X300

Gilad Beeri (ApolloShield) gilad at apolloshield.com
Sun Nov 12 05:20:06 EST 2017


Hi,
I'm trying to set-up a brand new just-opened USRP X300 with 10 GigE SFP+.

The equipment I have:

   1. X300 + a single SBX-120
   2. 2 Intel SFP+ 10 GigE cables
   3. Intel X710-DA4 NIC
   4. A motherboard with a standard Ethernet interface
   5. Ubuntu 16.04 with kernel 4.10.0-38
   6. i40e driver installed, version 2.3.6, firmware version 6.01.


I followed the instructions of setting up a USRP X300.

When connecting the SFP+ transceiver to port 0 an Ethernet cable between
the transceiver and my Ethernet NIC, ping was successful, finding the
device was successful, and I could successfully burn the necessary firmware
(HG). Note: tried both UHD 3.10.2 and 3.11.
So the USRP basically works.

Then tried connecting the SFP+ cable to port 0 -> no link (configured host
IP 192.168.10.1).
Tried connecting it to port 1 and configuring host IP 192.168.40.1 -> no
link. If I reboot the USRP when the cable is connected, only then the port
LEDs turn on (not when connecting the cable while the device is already
on), but still, no link is detected.

Does my Intel X710-DA4 work at all? First, the OS recognizes all 4
interfaces. Second, I put inside it Ettus's transceiver, and connected a
network cable from the X710 to my motherboard, configured a local network
and successfully pinged. So the X710 does work.

Do my Intel SFP+ 10 GigE cables work? Connected them at both ends to
SFP+-based computers and successfully transferred a file between them over
my SFP+ cables. So the cables work.

What else can I try?

Thanks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171112/80c0089e/attachment-0002.html>


More information about the USRP-users mailing list