[USRP-users] Problems with Ettus B210 and Intel Nuk

Neel Pandeya neel.pandeya at ettus.com
Wed Nov 1 16:41:05 EDT 2017


This issue seems to be related to USB bus power. For some reason, the USB
controller is not able to supply enough power at the initial enumeration of
the B210. This issue doesn't manifest on all USB controllers.

Here's some more information on the "device descriptor read/64, error -110"
error in "dmesg":

https://askubuntu.com/questions/644010/ubuntu-cant-read-my-usb-device-descriptor-read-64-error-110

https://stackoverflow.com/questions/13653692/device-descriptor-read-64-error-110

https://ubuntuforums.org/showthread.php?t=1610142

Can you confirm that if you press the S700 button on the board, that the
board is recognized on the USB bus and becomes responsive?

Does the problem go away if you use a USB 3.0 hub with DC power supply in
between the Intel NUC computer and the B210?

--​Neel Pandeya




On 31 October 2017 at 13:30, "Tathagata (T)" <tathagata at protonmail.ch>
wrote:

> That does not work. Here is an excerpt from dmesg followed by the commands:
>
> [    2.591180] IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready
> [    2.633612] IPv6: ADDRCONF(NETDEV_UP): wlp58s0: link is not ready
> [    2.899173] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
> [    2.899175] Bluetooth: BNEP filters: protocol multicast
> [    2.899177] Bluetooth: BNEP socket layer initialized
> [    6.267182] usb 1-2: device descriptor read/64, error -110
> [    7.338228] wlp58s0: authenticate with dc:ef:09:96:ad:2c
> [    7.341527] wlp58s0: send auth to dc:ef:09:96:ad:2c (try 1/3)
> [    7.347540] wlp58s0: authenticated
> [    7.348011] wlp58s0: associate with dc:ef:09:96:ad:2c (try 1/3)
> [    7.351852] wlp58s0: RX AssocResp from dc:ef:09:96:ad:2c (capab=0x1411
> status=0 aid=1)
> [    7.354224] wlp58s0: associated
> [    7.354248] IPv6: ADDRCONF(NETDEV_CHANGE): wlp58s0: link becomes ready
> [   22.135877] usb 1-2: device descriptor read/64, error -110
> [   22.399721] usb 1-2: new high-speed USB device number 3 using xhci_hcd
> [   27.765003] usb 1-2: device descriptor read/64, error -110
>
> root at ju:/usr/local/lib/uhd/utils# uhd_find_devices
> linux; GNU C++ version 5.4.0 20160609; Boost_105800;
> UHD_003.009.007-0-g50839059
>
> No UHD Devices Found
>
> root at ju:/usr/local/lib/uhd/utils# ./b2xx_fx3_utils --reset-device
> linux; GNU C++ version 5.4.0 20160609; Boost_105800;
> UHD_003.009.007-0-g50839059
>
> Cannot open device
> root at ju:/usr/local/lib/uhd/utils#
>
> Thanks
> T
>
>
> -------- Original Message --------
> Subject: Re: [USRP-users] Problems with Ettus B210 and Intel Nuk
> Local Time: October 31, 2017 4:06 PM
> UTC Time: October 31, 2017 8:06 PM
> From: nate.temple at ettus.com
> To: Neel Pandeya <neel.pandeya at ettus.com>
> "Humphries, James R." <humphriesjr at ornl.gov>, usrp-users at lists.ettus.com <
> usrp-users at lists.ettus.com>, tathagata at protonmail.ch
>
> Hi Tathagata,
>
> After you boot, if you run: $UHD_INSTALL_PREFIX/utils/b2xx_fx3_utils
> --reset-device
>
> Are you able to then initialize the USRP by running uhd_usrp_probe?
>
>
> Regards,
> Nate Temple
>
>
> On Oct 31, 2017, at 11:11 AM, Neel Pandeya via USRP-users
> usrp-users at lists.ettus.com wrote:
> Hello Tathagata:
> If I recall from a separate conversation, after you upgraded the BIOS on
> this Intel NUC, the system would no longer recognize the B210, right?
> Before the BIOS upgrade, the B210 would still be recognized, but only
> after a long 30- or 60-second delay, right?
> --Neel Pandeya
> On 31 October 2017 at 10:52, Humphries, James R. via USRP-users
> usrp-users at lists.ettus.com wrote:
> Hey T,
> I encountered a problem similar to this in the past with a Minnowboard
> Max. If you press the reset switch (S700 I believe), is the NUC able to see
> the B210 (instead of unplugging USB)? I had to do this if I had a B200
> plugged into the Minnowboard while it booted.
> The solution we came up with was to install a larger capacitor in parallel
> with C716/S700. I recall installing a 100uF capacitor. This allowed some
> extra time before the Cypress USB chip on the B200 powered up and it would
> work normally after a cold boot.
> Obviously, if you want to try I assume it will void your warranty on the
> B210, so proceed at your own risk.
> I think B200mini alleviated this ‘issue’ as it has a reset supervisor
> (TPS3801).
> -Trip
> From: USRP-users [mailto:usrp-users-bounces at lists.ettus.com
> <usrp-users-bounces at lists.ettus.com>] On Behalf Of "Tathagata (T)" via
> USRP-users
> Sent: Tuesday, October 31, 2017 12:09 AM
> To: usrp-users at lists.ettus.com
> Subject: [USRP-users] Problems with Ettus B210 and Intel Nuk
> Hi,
> We have a problem with Ettus B210 on an Intel Nuk. Briefly when we plug in
> the SDR into the USB port of the Intel Nuk, it is not recognized. The Nuk
> is running Ubuntu 16.04. The attached document details the debugging steps
> that we have taken and the errors that we are getting. We never had this
> problem before and it suddenly started and we have no clue as to what is
> going wrong. Any help would be highly appreciated.
> Thanks
> T
> ------------------------------
>
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
> ------------------------------
>
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20171101/fb7bb46a/attachment-0002.html>


More information about the USRP-users mailing list