[USRP-users] Having Installation Recognition Of Ettus E310 - Suggestions in Installing SDK for E310

Matheou, Konstantin J. (GRC-LCI0)[ZIN TECHNOLOGIES INC] konstantin.j.matheou at nasa.gov
Mon Jul 31 12:32:23 EDT 2017

OK...  I got a little further with the Install of SDK....  Also, have been reading up on Linux in general and its various commands...

I ran the below command, after giving it permissions to run as an executable.


Everything worked and I received the arm-oe-linux-gnueabi' after I did the $CC - dumpmachine command....  Woohoo!!!!!

Then I ran the following command as the below website suggests....


cmake -DCMAKE_TOOLCHAIN_FILE=../host/cmake/Toolchains/oe-sdk_cross.cmake -DCMAKE_INSTALL_PREFIX=/usr -DENABLE_E300=ON -DENABLE_GPSD=ON ..

Once I ran it, I received Something about a python 2.7 version not being installed...

Would anyone assist/comment on what I need done now????



From: USRP-users [mailto:usrp-users-bounces at lists.ettus.com] On Behalf Of Matheou, Konstantin J. (GRC-LCI0)[ZIN TECHNOLOGIES INC] via USRP-users
Sent: Monday, July 31, 2017 10:12 AM
To: Marcus Müller <marcus.mueller at ettus.com>; usrp-users at lists.ettus.com
Subject: Re: [USRP-users] Having Installation Recognition Of Ettus E310

Thank you very much for the clarification Mark.

Btw, I was using the B210 just until I received the E310... There will be not integration of the two... The plan is to just use the E310.

Unfortunately, I am a novice to linux.

So, it seems my last step is to install SDK.

The E310 is a 156333E-01L, so per a readme file I read, I need to install the release 4 image, and since I would like the QT tools, I need to install the  -dev file.

This is the website..   http://files.ettus.com/e3xx_images/  where it shows to access the files..

Do I download them?  How do I run the command below?  When I try running it (even with sudo since I am in a VM), I get an error

Now it seems I need to run the ./oecore-x86_64-armv7ahf-vfp-neon-toolchain-nodistro.0.sh

I appreciate the assistance.


From: USRP-users [mailto:usrp-users-bounces at lists.ettus.com] On Behalf Of Marcus Müller via USRP-users
Sent: Monday, July 31, 2017 2:54 AM
To: usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>
Subject: Re: [USRP-users] Having Installation Recognition Of Ettus E310

Hello Konstantin,

So, the most important difference to be made here is that while the B210 is used as a peripheral to a PC, the E310 includes the host computer itself. So, the signal processing software doing whatever you want to do has to run on the E310 itself.

So, what you'd normally do is a development circle that looks something like:

  1.  On a PC, implement signal processing software that would do what you want if running on the E310. In your case, you can verify that by using the B210. Make sure that the software doesn't use more CPU and memory bandwidth than the E310 has to offer.
  2.  If necessary, cross-compile the software for the E310, copy the resulting executable over to the E310's storage, and run it on the E310. Verify operation, improve the software (back to step 1).

That cross-compiling is what you need the SDK for.

Now, you'll be working with the Linux that is running on the E310. This might be a good time to point out that some proficiency with Linux is necessary when developing for an embedded device that is running that OS; so, honestly, I'd be sure to feel very comfortable with working with the B210 under Linux before even starting with the E310. As the E310 is kind of special-purpose for applications where size and ruggedness are more important to have than CPU power, you might come into a situation where you'd also have to write some FPGA infrastructure - all these are complicating matters, so again, be very comfortable with Linux before diving into embedded Linux development! I'm personally not very emotional about these matters, but it might be fair to say that at that point, you'll necessarily be doing all your dev work in a Linux environment, so that one would wonder why you'd be running Linux in a VM to start with.

Best regards,

On 07/30/2017 10:29 PM, Matheou, Konstantin J. (GRC-LCI0)[ZIN TECHNOLOGIES INC] via USRP-users wrote:
To All,

First thank you for your help for the previous installation issue I had with the  B210.  But now, the E310 came in and there is a different installation process as most of us know.  Unfortunatley, I am not 100% connected correctly with the E310 and need the forum' s assistance.

This is the scenario:

1)      Using Oracle VirtualBox software to create a Ubuntu Linux OS 16.04 on a Window 7 64-bit machine

2)      Since the B210 worked using the above Virtual Machine (VM) setup, I figure I can get the E310 to work.  So, using the same machine as before, thus the same USB Windows drivers are still installed that allowed the B210 to be installed through the Windows 7 64-bit initial hardware

3)      I installed UDN and GRC already on the linux VM machine

4)      I setup things correctly to be USB 2.0 in the Oracle VM setup.  I also have the FTDI as filtered in the Oracle VMware setup

5)      When I open a terminal and use this command to get to a sudo screen /dev/ttyUSB0  115200, I get to the login of the E310 hardware via this terminal command - Is there anything here I can do to validate that things are working?

6)      Then when I turn the E310 off and then on, I get all of this installing of stuff in the above E310 terminal screen.  I am assuming this is OK.

This is where I am at..

Now my questions?

Do I have to install SDK?  If yes, what is the best way to do so?

Is there anything else I m missing...

For the B210, I used the commands form a Linux terminal UHD_find_devices and UHD_usrp_probe to get things working... do I use the same commands for the E310.

I appreciate any assistance...



USRP-users mailing list

USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20170731/2520d833/attachment-0002.html>

More information about the USRP-users mailing list