[USRP-users] ABI compatibility mismatch error

Martin Braun martin.braun at ettus.com
Tue Jul 18 12:27:29 EDT 2017


How did you install GNU Radio and UHD, respectively?

-- M

On 07/18/2017 09:24 AM, Matheou, Konstantin J. (GRC-LCI0)[ZIN
TECHNOLOGIES INC] via USRP-users wrote:
> I finally got things connected to the B210, and now I am having
> software/firmware compatibility issues.
> 
>  
> 
> I did do searches for this issue already on the net, but the
> instructions are very vague.
> 
>  
> 
> I already tried to uninstall GNU radio and reinstall.
> 
>  
> 
> The current version I have is 3.7.9.rc1.
> 
>  
> 
> GR-UHD was built against ABI: 3.9.0-0
> 
> But the UHD library reports ABI 3.10.1
> 
>  
> 
> Install a compatible version of UHD.
> 
>  
> 
>  
> 
> How do I do this?  Is there a simple link somewhere to download the
> correct software?
> 
>  
> 
> I am using Ubuntu 16.04 and oracle Virtualbox
> 
>  
> 
> Thanks again for any assistance.
> 
>  
> 
> Konstantin
> 
>  
> 
>  
> 
> 
> 
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
> 





More information about the USRP-users mailing list