[USRP-users] TwinRx not recieving waveform

Brandon Dunn bdunn5945 at yahoo.com
Tue Jul 18 10:59:22 EDT 2017


Hi Derek,GNUradio starts but the tones(900Mhz and 900.4Mhz) being created by the signal generators does not show up where it should near the center frequency set(898Mhz). The flow chart works for other radios but this twinRx board doesn't want to work. The file I am talking about is the db_twinrx.cpp file under uhd/host/lib/usrp/dboard. uhd_usrp_probe runs correctly but it shows the board as "unknown" but the correct code is shown for the twinrx(x091 - something). I am seeing only noise and center frequency but I have increased the gain to 70 and it still showed the same. I believe the problem is that GNUradio and UHD has been installed many times on the computer i am using with both pybombs and gnuradio/build(another method). I can't seem to run uhd_fft as it can't find it. I am using ubuntu. When i try to locate uhd_fft i get the following.

/home/wireless/Pictures/CPU% for uhd_fft at high sampling rate.png
/home/wireless/gnuradio/build/gr-uhd/apps/uhd_fft.exe
/home/wireless/gnuradio/gr-uhd/apps/uhd_fft
/home/wireless/gnuradio/gr-uhd/apps/uhd_fft_wx
/home/wireless/gnuradio/gr-uhd/examples/grc/uhd_fft.grc
/home/wireless/pybombs/src/gnuradio/build/gr-uhd/apps/uhd_fft.exe
/home/wireless/pybombs/src/gnuradio/gr-uhd/apps/uhd_fft
/home/wireless/pybombs/src/gnuradio/gr-uhd/examples/grc/uhd_fft.grc
/home/wireless/target/bin/uhd_fft
/home/wireless/target/share/gnuradio/examples/uhd/uhd_fft.grc
/usr/local/bin/uhd_fft
/usr/local/share/gnuradio/examples/uhd/uhd_fft.grc


 

   

 On Tuesday, July 18, 2017 3:41 AM, Derek Kozel <derek.kozel at ettus.com> wrote:
 

 Hello Brandon,

How did you install UHD and GNU Radio? When you say that the USRP is not receiving the waveform, do you see just noise or does the application not even start? What file was missing, there should definitely not be anything missing from those versions.

I recommend ensuring that uhd_usrp_probe runs correctly and shows the X310 and TwinRX, then try using uhd_fft which comes with GNU Radio to see a spectrum plot. If you are seeing only noise my guess is that you need to increase the receive gain. The TwinRX has a very large gain range. Starting around index 70 is usually good.

uhd_fft --freq 2e9 --gain 70

Regards,
Derek

On Mon, Jul 17, 2017 at 9:01 PM, Brandon Dunn via USRP-users <usrp-users at lists.ettus.com> wrote:

Hello,I am fairly new to usrp's and i am having troubles getting a waveform from a x310 with one TwinRX daughterboard acting as a receiver. I am using 2 signal generators to generate the waveform. My UHD version is 3.10.something (the newest auto-downloaded version). I am using GNU-radio to show this waveform which is version 3.7.11.1. I found that the TwinRX .cpp was not in the required folder so i downloaded that from github and put it in the correct folder. I don't see what I could be doing wrong. Can someone help me?
Thanks,Brandon

______________________________ _________________
USRP-users mailing list
USRP-users at lists.ettus.com
http://lists.ettus.com/ mailman/listinfo/usrp-users_ lists.ettus.com





   
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20170718/7265771c/attachment-0002.html>


More information about the USRP-users mailing list