[USRP-users] Very Close - Trying to Connect B210 Using VMware

Matheou, Konstantin J. (GRC-LCI0)[ZIN TECHNOLOGIES INC] konstantin.j.matheou at nasa.gov
Sat Jul 15 21:51:32 EDT 2017


Leo, Thanks for the try…

I understand your point, but I go to the dropdown menu and choose the Ettus 210 again, and I hear the USB beep “meanin its connected”, but when I do the uhd_find_devices command again (after firmware was installed), I still get the No connection…

Now, I did take another route…  I used the uhd_usrp_probe command to try to connect to the B210/200  and it loaded the firmware image file called usrp_b200_fw.hex file, but then I received and error called lookupError and KeyError
No Devicess Found --> Empty Device Address.

I went back to check the previous advice I received from Nate and the VendorID = 2500 and ProductID = 0020.

I know it has something to do with the communication setup with Vitrtualbox…   Or maybe it is a config setup in the usrp_b200_fw.hex file…

I will be sniffing up these 2 routes….

Again, any advice is appreciated

From: Leandro Echevarría [mailto:leoechevarria at gmail.com]
Sent: Saturday, July 15, 2017 8:56 PM
To: Matheou, Konstantin J. (GRC-LCI0)[ZIN TECHNOLOGIES INC] <konstantin.j.matheou at nasa.gov>; Jacqueline.Walker <Jacqueline.Walker at ul.ie>
Cc: usrp-users at lists.ettus.com
Subject: Re: [USRP-users] Very Close - Trying to Connect B210 Using VMware

Hi Matheou,

When using Virtualbox and a X310 connected through USB, every time the Ettus rebooted after an image updating I had to go the Virtualbox menu and select the device again from the list of connected USB devices to make the virtual machine recognize it. Perhaps you're skipping this step?

Regards,

Leo.

On Sat, Jul 15, 2017 at 5:08 PM Matheou, Konstantin J. (GRC-LCI0)[ZIN TECHNOLOGIES INC] via USRP-users <usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>> wrote:
I have followed Nate's advice, at least I think, and things are still not working...

Again, the firmware is loading (thus assuming USB connection is recognizing unit and transmitting info), but once the software process of loading the firmaware is done, I hear the unhooking Windows sound of a USB device and then I get the no Devices Loaded message in the screen.

I hope to figure this out this weekend.  If not, I will try to get a laptop that has Linux loaded already on the laptop/PC.

Thanks

-----Original Message-----
From: USRP-users [mailto:usrp-users-bounces at lists.ettus.com<mailto:usrp-users-bounces at lists.ettus.com>] On Behalf Of Jacqueline.Walker via USRP-users
Sent: Saturday, July 15, 2017 11:54 AM
To: usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>
Subject: Re: [USRP-users] Very Close - Trying to Connect B210 Using VMware

Hi,

I have a similar problem with a B200 on a Linux VM (archlinux) but I am using VMware (Workstation Player 12). I do have USB 3.0 enabled and the VM can see a USB 3.0 hard drive but it can't see the B200. Is there a similar solution for  VMware ?

thanks
Jacqueline
________________________________________
From: USRP-users [usrp-users-bounces at lists.ettus.com<mailto:usrp-users-bounces at lists.ettus.com>] on behalf of Nate Temple via USRP-users [usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>]
Sent: 14 July 2017 18:33:28
To: Matheou, Konstantin J. (GRC-LCI0)[ZIN TECHNOLOGIES INC]
Cc: usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>
Subject: Re: [USRP-users] Very Close - Trying to Connect B210 Using VMware

Hi Konstanitn,

I assume you mean you are using VirtualBox, not VMWare.

You will need to add a USB Filtering rule for the USRP within the settings for the virtual machine (within VirtualBox settings).

You will need to add a rule for VID: 2500 PID: 0020 for the B210.

Also, you need replace the value "<install-path>" with the path to which UHD is installed, commonly this is /usr/local/. uhd_images_downloader will be located /usr/local/lib/uhd/utils/uhd_image_downloader.py

Regards,
Nate Temple


> On Jul 14, 2017, at 9:28 AM, Matheou, Konstantin J. (GRC-LCI0)[ZIN TECHNOLOGIES INC] via USRP-users <usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>> wrote:
>
>
> Hello to everyone.  I am a novice to the B210.  My main first task is to hookup the B210 to the laptop via  Oracle VMware (Virtual machine).
>
> I realize this may not be the most admired approach, but I think i am very close in getting the B210 connected.  btw, after many hours of hurdles that i found out already.
>
> I hope you can review the screen shot first.
> Comments/Facts
>
> 1) the B210 is USB 3.0
> 2) I already installed Windows host.guest USB 3.0 driver and Oracle VMware extensions pack to allow the USB 3.0 to pass from the Windows 7 OS to the virtual Ubuntu 16.04 OS.  I hear the beep noise when I open the Vmware software.  Thus, giving a good sign that the Linux OS as detected the USB 3.0 port of the B210.
> 3)  When running the 'uhd_find_devices' at the terminal prompt, a message come up stating that I needed to update the B210 image by running the folling python code -/usr/lib/uhd/utils/uhd_images_downloader.py - This seemed to update a driver.
> 4) I then unplugged the B210 and reset the Linux software.
> 5) But then when I ran the 'uhd_find_devices' command in the terminal, i received No UHD Devices Found.
>
> At this time, I am out of ideas, thus if anyone can help out in assisting me in getting tthings connected with the current approach.
>
> Thanks
>
> Konstanitn
>
>
>
> Have a little more info that might help.  Look at the screenshot.  i have a B210, but it shows it is trying to load a b200 hex file to firmware.  This happens when I unplug and plug the USB port in.  May this be the issue?
>
> Thanks
>
>
>
> <image.png><image1.png>_______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com


_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20170716/b74af1b2/attachment-0002.html>


More information about the USRP-users mailing list