[USRP-users] Very Close - Trying to Connect B210 Using VMware

Nate Temple nate.temple at ettus.com
Fri Jul 14 13:33:28 EDT 2017


Hi Konstanitn,

I assume you mean you are using VirtualBox, not VMWare.

You will need to add a USB Filtering rule for the USRP within the settings for the virtual machine (within VirtualBox settings). 

You will need to add a rule for VID: 2500 PID: 0020 for the B210.

Also, you need replace the value "<install-path>" with the path to which UHD is installed, commonly this is /usr/local/. uhd_images_downloader will be located /usr/local/lib/uhd/utils/uhd_image_downloader.py

Regards,
Nate Temple


> On Jul 14, 2017, at 9:28 AM, Matheou, Konstantin J. (GRC-LCI0)[ZIN TECHNOLOGIES INC] via USRP-users <usrp-users at lists.ettus.com> wrote:
> 
>  
> Hello to everyone.  I am a novice to the B210.  My main first task is to hookup the B210 to the laptop via  Oracle VMware (Virtual machine).
>  
> I realize this may not be the most admired approach, but I think i am very close in getting the B210 connected.  btw, after many hours of hurdles that i found out already.
>  
> I hope you can review the screen shot first.
> Comments/Facts
>  
> 1) the B210 is USB 3.0
> 2) I already installed Windows host.guest USB 3.0 driver and Oracle VMware extensions pack to allow the USB 3.0 to pass from the Windows 7 OS to the virtual Ubuntu 16.04 OS.  I hear the beep noise when I open the Vmware software.  Thus, giving a good sign that the Linux OS as detected the USB 3.0 port of the B210.
> 3)  When running the 'uhd_find_devices' at the terminal prompt, a message come up stating that I needed to update the B210 image by running the folling python code -/usr/lib/uhd/utils/uhd_images_downloader.py - This seemed to update a driver.
> 4) I then unplugged the B210 and reset the Linux software.
> 5) But then when I ran the 'uhd_find_devices' command in the terminal, i received No UHD Devices Found.
>  
> At this time, I am out of ideas, thus if anyone can help out in assisting me in getting tthings connected with the current approach.
>  
> Thanks
>  
> Konstanitn
>  
>  
>  
> Have a little more info that might help.  Look at the screenshot.  i have a B210, but it shows it is trying to load a b200 hex file to firmware.  This happens when I unplug and plug the USB port in.  May this be the issue?
> 
> Thanks
>  
>  
>  
> <image.png><image1.png>_______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com





More information about the USRP-users mailing list