[USRP-users] Issues/suggestions for latest rfnocmodtool

Michael Wentz mchlwntz at gmail.com
Wed Jul 12 16:04:03 EDT 2017


Hi,

I just pulled the latest rfnoc-devel and gr-ettus updates. After resolving
dependencies (I was missing the python2-future package), I had the
following problem:

    rfnocmodtool newmod test
    Traceback (most recent call last):
      File "/opt/rfnoc/bin/rfnocmodtool", line 27, in <module>
        main()
      File "/opt/rfnoc/bin/rfnocmodtool", line 22, in main
        print(err, file=sys.stderr)
    NameError: global name 'sys' is not defined

It seems that 'import sys' is missing from the top of
gr-ettus/python/utils/rfnocmodtool

After changing that, I ran into this problem:

    rfnocmodtool newmod test
    Could not find rfnoc-newmod source dir

It turns out that gr-ettus/modtool_newmod.py is not set up for people that
do not use PYBOMBS but do have a custom install prefix. All I had to do was
copy that over to PYBOMBS_PREFIX and then newmod worked. I would have
thought my install prefix would have been set up in any necessary files
during cmake?

I was also wondering if there are reasons why underscores are not allowed
in block names, and why the QA templates were removed (I liked using these
to do tests with hardware in the loop)?

-Michael
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20170712/1076a9a2/attachment-0002.html>


More information about the USRP-users mailing list