[USRP-users] ERROR_CODE_BAD_PACKET

Jason Matusiak jason at gardettoengineering.com
Mon Jul 10 13:15:09 EDT 2017


Hi Marcus,

I tried axi_wrapper in both SIMPLE_MODE and advanced.  When not in 
SIMPLE_MODE, I setup s_axis_data_tuser like this:
  wire [63:0] vita_time;
   wire has_time;
   wire eob;
   wire [1:0] pkt_type;
   wire [15:0] length_adj;

   assign has_time = m_axis_data_tuser[125];
   assign eob = m_axis_data_tuser[124];
   assign pkt_type = m_axis_data_tuser[127:126];
   assign vita_time = m_axis_data_tuser[63:0];

   assign length_adj = (4 + (has_time ? 16'd16 : 16'd8));

   assign s_axis_data_tuser = {pkt_type, // DATA packet
                                  has_time, // Has VITA time field?
                                  eob, // End of burst
                                  12'd0, // Don't care, AXI wrapper 
handles sequence number internally
                                  length_adj, // ... and packet length
                                  src_sid, // Source SID (aka this block 
port's SID)
                                  next_dst_sid, // Destination SID
                                  vita_time};

(where src_sid and nex_dst_sid are outputted from the noc_shell)

The length_adj seems odd to me, but I've had to use it in the past when 
I was doing vectors (it would be 4*PKT_SIZE), should I do something 
different there for a stream?


On 07/10/2017 01:09 PM, Marcus Müller wrote:
> Sounds like the header might have not been adapted 100% correctly. 
> Check whether your noc shell has the right fields set.
>
> Cheers,
> Marcus
>
> On 10 July 2017 7:03:57 PM GMT+02:00, Jason Matusiak via USRP-users 
> <usrp-users at lists.ettus.com> wrote:
>
>     I am splitting one of my RFNoC blocks into two different ones, and one
>     of them is giving me issues.  The block is essentially a keep m in n
>     block, so I only spit out data once in a while.  This worked fine when
>     combined with my other block, but now when I run it independently, it is
>     throwing this error whenever I send the samples across (one error
>     message per dump of data it seems:
>
>     [RFNoC Streamer block received error ERROR] ERROR_CODE_BAD_PACKET[
>     (Code: 0xSTREAMERf] )The receive packet handler caught a value exception.
>     ValueError: Bad CHDR or packet fragment
>
>
>     Any idea the best way to debug this?
>
>
>     ------------------------------------------------------------------------
>
>     USRP-users mailing list
>     USRP-users at lists.ettus.com
>     http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
> -- 
> Sent from my Android device with K-9 Mail. Please excuse my brevity. 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20170710/70aeb468/attachment-0002.html>


More information about the USRP-users mailing list