[USRP-users] ERROR_CODE_BAD_PACKET

Marcus Müller marcus.mueller at ettus.com
Mon Jul 10 13:09:08 EDT 2017


Sounds like the header might have not been adapted 100% correctly. Check whether your noc shell has the right fields set.

Cheers,
Marcus

On 10 July 2017 7:03:57 PM GMT+02:00, Jason Matusiak via USRP-users <usrp-users at lists.ettus.com> wrote:
>I am splitting one of my RFNoC blocks into two different ones, and one 
>of them is giving me issues.  The block is essentially a keep m in n 
>block, so I only spit out data once in a while.  This worked fine when 
>combined with my other block, but now when I run it independently, it
>is 
>throwing this error whenever I send the samples across (one error 
>message per dump of data it seems:
>
>[RFNoC Streamer block received error ERROR] ERROR_CODE_BAD_PACKET[ 
>(Code: 0xSTREAMERf] )The receive packet handler caught a value
>exception.
>ValueError: Bad CHDR or packet fragment
>
>
>Any idea the best way to debug this?
>
>
>_______________________________________________
>USRP-users mailing list
>USRP-users at lists.ettus.com
>http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20170710/915692f6/attachment-0002.html>


More information about the USRP-users mailing list