[USRP-users] rfnocmodtool test bench

Prasanthi Maddala prasanti at winlab.rutgers.edu
Thu Jul 6 12:25:27 EDT 2017


Hi,

   I am trying to test a custom block built using rfnocmodtool and I get
this error when I run make noc_block_<my_block>_tb

*Setting up a 64-bit FPGA build environment for the USRP-X3x0...*
*- Vivado: Found (/opt/Xilinx/Vivado/2015.4/bin)*
*- Vivado HLS: Found (/opt/Xilinx/Vivado_HLS/2015.4/bin)*

*Environment successfully initialized.*
*Makefile:12: /usrp3/top/../tools/make/viv_sim_preamble.mak: No such file
or directory*
*Makefile:34: /usrp3/top/../tools/make/viv_simulator.mak: No such file or
directory*
*make[4]: *** No rule to make target
`/usrp3/top/../tools/make/viv_simulator.mak'.  Stop.*
*make[3]: *** [CMakeFiles/noc_block_spreader_tb] Error 2*
*make[2]: *** [CMakeFiles/noc_block_spreader_tb.dir/all] Error 2*
*make[1]: *** [CMakeFiles/noc_block_spreader_tb.dir/rule] Error 2*

When I run
 * cmake -DUHD_FPGA_DIR=/root/uhd/fpga-src/ ../*

I see the following
*checking for module 'fpga'*
*--   package 'fpga' not found*
*-- Found FPGA: /root/uhd/fpga-src*

Not sure what is going wrong. Can someone please help..

thanks,
- Prasanthi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20170706/3bbfddad/attachment-0002.html>


More information about the USRP-users mailing list