[USRP-users] E312 SD Card File System Corruption

Nate Temple nate.temple at ettus.com
Wed Jul 5 20:17:07 EDT 2017


Hi Darek,

Were you able to resolve this? Does the problematic E312 work with a fresh
release-4 image?

Are you trying to copy it to /prefix/ or to a subdirectory within your
/home/root (/home/root/prefix/) ?

What happens if you mount a remote file system via SSHFS and then copy the
files via the mounted location, to avoid scp ?

Regards,
Nate Temple

On Tue, May 16, 2017 at 2:49 PM, Darek Kawamoto via USRP-users <
usrp-users at lists.ettus.com> wrote:

> Hey all,
>
> I've got an E312 that I'm working on, and whenever I try to scp my working
> prefix onto the SD card I get a bunch of errors seemingly related to the SD
> card.  In my scp output I get errors like this for each remaining file:
>
> scp: /prefix/lib/libgnuradio-runtime-3.7.12git.so.0.0.0: Read-only file
> system
>
> And the dmesg on the E312 says a ton stuff like this:
>
> [  407.967600] end_request: I/O error, dev mmcblk0, sector 11386400
> [  407.983805] mmc0: Controller never released inhibit bit(s).
> [  407.991328] mmcblk0: error -5 sending status command, retrying
> [  407.999109] mmcblk0: error -110 sending status command, retrying
> [  408.007060] mmcblk0: error -110 sending status command, aborting
> [  408.051219] mmc0: Controller never released inhibit bit(s).
> [  408.058776] mmcblk0: error -5 sending status command, retrying
> [  408.066598] mmcblk0: error -110 sending status command, retrying
> [  408.074595] mmcblk0: error -110 sending status command, aborting
> [  408.080598] EXT4-fs warning (device mmcblk0p2):
> __ext4_read_dirblock:908: error reading directory block (ino 1312422, block
> 0)
> [  409.148499] mmc0: Controller never released inhibit bit(s).
> [  409.156026] mmcblk0: error -5 sending status command, retrying
> [  409.163825] mmcblk0: error -110 sending status command, retrying
> [  409.171804] mmcblk0: error -110 sending status command, aborting
> [  409.177727] blk_update_request: 2 callbacks suppressed
> [  409.182862] end_request: I/O error, dev mmcblk0, sector 21140864
>
> etc. etc.
> I'm able to put this SD card into another E312 which doesn't have this
> problem and things work just fine.  If I move a known-working SD card from
> the working E312 into the broken one, this problem happens.  So this seems
> to indicate that the broken part is not the SD card.
>
> Has anyone seen this before / any ideas on how to fix this?
>
> Darek
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20170705/aa5716f3/attachment-0002.html>


More information about the USRP-users mailing list