[USRP-users] Error using RFNoC OFDM Sync block on E310

Sergio Cruz Perez serchsype at hotmail.com
Thu Mar 24 14:35:08 EDT 2016


Hi Jonathon,
I'm using commit b7546712aa0091f87b793ef4c4a9e9c084467173
Thanks
Sergio
From: jonathon.pendlum at ettus.com
Date: Wed, 23 Mar 2016 20:12:59 -0700
Subject: Re: [USRP-users] Error using RFNoC OFDM Sync block on E310
To: serchsype at hotmail.com
CC: usrp-users at lists.ettus.com

Hi Sergio,
Looks like the block is being enumerated but UHD is not populating the property tree correctly. What commit of UHD rfnoc-devel are you using?


Jonathon
On Wed, Mar 23, 2016 at 11:15 AM, Sergio Cruz Perez <serchsype at hotmail.com> wrote:



Hi Jonathon,

Finally I could make the image updating the e300_core.v file as you said. I ran the uhd_usrp_probe init only and now I can see the rfnoc blocks schmidl_cox and fifo.
-- ========== Full list of RFNoC blocks: ============-- * 0/Radio_0-- * 0/Radio_1-- * 0/FIFO_0-- * 0/SchmidlCox_0
But, when i run my application I got again the same problem:
...
-- [0/SchmidlCox_0] _resolve_port_def()-- [0/SchmidlCox_0]   item type: sc16-- [0/SchmidlCox_0]   vector length: 0-- [0/SchmidlCox_0]   packet size: 0-- [0/SchmidlCox_0] _resolve_port_def()-- [0/SchmidlCox_0]   item type: sc16-- [0/SchmidlCox_0]   vector length: 64-- [0/SchmidlCox_0]   packet size: 64-- [NocScript] Executing and asserting code: SR_WRITE("CP_LENGTH", $cp_len)-- [NocScript] Executing SR_WRITE() --   [0/SchmidlCox_0] sr_write(CP_LENGTH, 00000040) ==>   [0/SchmidlCox_0] sr_write(130, 00000040, 0)-- [NocScript] Executing and asserting code: GE($threshold, 0.0) AND LE($threshold, 1.0)-- [NocScript] Executing and asserting code: SR_WRITE("THRESHOLD", IROUND(MULT(32768.0, $threshold)))-- [NocScript] Executing SR_WRITE() --   [0/SchmidlCox_0] sr_write(THRESHOLD, 00007000) ==>   [0/SchmidlCox_0] sr_write(134, 00007000, 0)Traceback (most recent call last):  File "./rx_rfnoc.py", line 207, in <module>    main()  File "./rx_rfnoc.py", line 196, in main    tb = top_block_cls(chan_est=options.chan_est, freq=options.freq, gain=options.gain, lo_offset=options.lo_offset, samp_rate=options.samp_rate)  File "./rx_rfnoc.py", line 97, in __init__    self.uhd_rfnoc_ofdm_schmidlcox_0.set_arg("offset", 77)  File "/usr/local/lib/python2.7/site-packages/ettus/ettus_swig.py", line 3002, in set_arg    return _ettus_swig.rfnoc_generic_sptr_set_arg(self, *args)RuntimeError: LookupError: Path not found in tree: /mboards/0/xbar/SchmidlCox_0/args/0/offset/value...
How is that path generated? I can't find it on the E310



From: jonathon.pendlum at ettus.com
Date: Tue, 22 Mar 2016 15:17:40 -0700
Subject: Re: [USRP-users] Error using RFNoC OFDM Sync block on E310
To: serchsype at hotmail.com
CC: usrp-users at lists.ettus.com

Sergio,
rfnoc-ofdm has gotten a little out of sync with UHD rfnoc-devel. The compat number on line 172 in e300_core.v needs to be updated to RB32_CORE_COMPAT  : rb_data <= {8'hAC, 8'h0, 8'h255, 8'h0};
I am going to merge rfnoc-ofdm into rfnoc-radio-redo soon which will fix this issue. This temporary fix should hold you over until the merge.


Jonathon
On Tue, Mar 22, 2016 at 3:07 PM, Sergio Cruz Perez <serchsype at hotmail.com> wrote:




Hi Jonathon,
It's a GNU radio flowgraph and I'm using my rfnoc fpga image. I copied the image that I made on my PC using the rfnoc-ofdm branches to the E310. My flowgraph has the root to that image in the device3 args so when I run my applications I can see that it's loading my image.
root at ettus-e300:~/pruebas# ./rx_rfnoc.py linux; GNU C++ version 4.9.2; Boost_105700; UHD_003.010.rfnoc-316-gb7546712
-- Loading FPGA image: /home/root/sheko/usrp_e310_rfnoc_fpga.bit... done-- Initializing core control...-- Performing register loopback test... pass .....
When I don't use the rfnoc-ofdm branches I can make the image and run it on the E310 but I return to the first problem of this thread. 
Thanks
Sergio
From: jonathon.pendlum at ettus.com
Date: Tue, 22 Mar 2016 14:23:28 -0700
Subject: Re: [USRP-users] Error using RFNoC OFDM Sync block on E310
To: serchsype at hotmail.com
CC: usrp-users at lists.ettus.com

Hi Sergio,
You need copy your bitstream to the E310 and replace /usr/share/uhd/images/usrp_e300_fpga.bit. How are you running your application? Is it a GNU Radio flowgraph?


Jonathon
On Tue, Mar 22, 2016 at 10:56 AM, Sergio Cruz Perez <serchsype at hotmail.com> wrote:




Hi Jonathon,
I installed  uhd rfnoc-devel version with the rfnoc-ofdm branches on both the PC and the E310 (UHD_003.010.rfnoc-316-gb7546712). I made the image with the schmidl_cox block but  when I run my application, I got the next error:
RuntimeError: Expected FPGA compatibility number 255.x, but got 7.0:The FPGA build is not compatible with the host code build.
What should I update on my PC to make a compatible image with the E310? 
RegardsSergio


From: jonathon.pendlum at ettus.com
Date: Wed, 9 Mar 2016 13:05:58 -0800
Subject: Re: [USRP-users] Error using RFNoC OFDM Sync block on E310
To: serchsype at hotmail.com
CC: usrp-users at lists.ettus.com

Hi Sergio,
Try using the "rfnoc-ofdm" branches for uhd and gr-ettus and rebuild your FPGA image. Make sure to add the schmidl_cox block to rfnoc_e310_ce_auto_inst.v and run 'make cleanall' before building the FPGA image.


Jonathon
On Tue, Mar 8, 2016 at 8:31 PM, Sergio Cruz Perez <serchsype at hotmail.com> wrote:



Hi Jonathon,
Yes, I followed the RFNoC:Getting started guide to install the rfnoc-devel branch and the gr-ettus  OOT module. I forgot to mention that in my first attempt to make the fpga image I had the next error:
ERROR: [Synth 8-448] named port connection 's_axis_phase_tlast' does not exist for instance 'cfo_corrector' of module 'cordic_rotator' [/home/sheko/uhd/fpga-src/usrp3/lib/rfnoc/schmidl_cox.v:163]
I removed that port in the schmidl_cox.v file and then it was possible to make the image with the schmidl_cox block.
Thanks 
Sergio





From: jonathon.pendlum at ettus.com
Date: Tue, 8 Mar 2016 16:51:20 -0800
Subject: Re: [USRP-users] Error using RFNoC OFDM Sync block on E310
To: serchsype at hotmail.com
CC: usrp-users at lists.ettus.com

Hi Sergio,
Are you using the rfnoc-ofdm branches for uhd and gr-ettus?


Jonathon
On Tue, Mar 8, 2016 at 4:31 PM, Sergio Cruz Perez via USRP-users <usrp-users at lists.ettus.com> wrote:




Hi,
I'm learning to use RFNoC to implement an  OFDM receiver on a E310.  The original FPGA image had just 3 RFNoC blocks: FIFO, Window and FFT, so I made a new image removing the window and the FFT blocks and replacing them for a schmidl_cox block. When I run my application with the new image I get the next error:
File "/usr/local/lib/python2.7/site-packages/ettus/ettus_swig.py", line 3002, in set_argreturn _ettus_swig.rfnoc_generic_sptr_set_arg(self, *args)
RuntimeError: LookupError: Path not found in tree: /mboards/0/xbar/SchmidlCox_0/args/0/offset/value
Has anyone run into the same problem?
I'm using UHD_003.010.rfnoc-314-gf773e72b
Thanks
Sergio Cruz

 		 	   		  

_______________________________________________

USRP-users mailing list

USRP-users at lists.ettus.com

http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com



 		 	   		  

 		 	   		  

 		 	   		  

 		 	   		  

 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20160324/a4249074/attachment-0002.html>


More information about the USRP-users mailing list