[USRP-users] GPS and UHD Time Alignment

devin kelly dwwkelly at gmail.com
Wed Mar 23 16:29:33 EDT 2016


Hello,

I'm on UHD 3.9.2 and I've been having some problems with aligning the UHD
time and GPS time on my X310.  My GPS, as far as I can tell, acquires and
maintains lock fine.  However, everytime I run query_gpsdo_sensors the UHD
and GPS time are not aligned (UHD time is always some low number like 1,2
or 3).

I downloaded the the master copy query_gpsdo_sensors here:

https://github.com/EttusResearch/uhd/blob/master/host/utils/query_gpsdo_sensors.cpp

And built it against 3.9.2, everything works seems to work fine when I run
it:

Time source is now gpsdo
GPS Locked
Setting the reference clock source to "gpsdo"...

Clock source is now gpsdo
**************************************Helpful Notes on Clock/PPS
Selection**************************************
As you can see, the default 10 MHz Reference and 1 PPS signals are now from
the GPSDO.
If you would like to use the internal reference(TCXO) in other
applications, you must configure that explicitly.
****************************************************************************************************************
USRP Locked to GPSDO 10 MHz Reference.

GPS and UHD Device time are NOT aligned;
last_pps: 3 vs gps: 1458764120. Trying to set the device time to GPS time...
--     1) catch time transition at pps edge
--     2) set times next pps (synchronously)
last_pps: 1458764124 vs gps: 1458764124.
GPS and UHD Device time are aligned.
Printing available NMEA strings:
GPS_GPGGA:
$GPGGA,201524.00,4227.5889,N,07116.0425,W,2,10,1.2,86.8,M,-33.1,M,,*68
GPS_GPRMC: $GPRMC,201524.00,A,4227.5889,N,07116.0425,W,0.0,0.0,230316,,*29
GPS Epoch time at last PPS: 1458764124.00000 seconds
UHD Device time last PPS:   1458764124.00000 seconds
UHD Device time right now:  1458764124.24561 seconds
PC Clock time:              1458764124 seconds

GPS and UHD time aren't aligned but query_gpsdo_senors aligns them for me
fine.  However if I run querry_gpsdo_sensors again the clocks are
un-aligned again!

Time source is now gpsdo
GPS Locked
Setting the reference clock source to "gpsdo"...

Clock source is now gpsdo
**************************************Helpful Notes on Clock/PPS
Selection**************************************
As you can see, the default 10 MHz Reference and 1 PPS signals are now from
the GPSDO.
If you would like to use the internal reference(TCXO) in other
applications, you must configure that explicitly.
****************************************************************************************************************
USRP Locked to GPSDO 10 MHz Reference.

GPS and UHD Device time are NOT aligned;
last_pps: 3 vs gps: 1458764770. Trying to set the device time to GPS time...
--     1) catch time transition at pps edge
--     2) set times next pps (synchronously)
last_pps: 1458764774 vs gps: 1458764774.
GPS and UHD Device time are aligned.
Printing available NMEA strings:
GPS_GPGGA:
$GPGGA,202614.00,4227.5830,N,07116.0439,W,2,11,1.0,80.9,M,-33.1,M,,*60
GPS_GPRMC: $GPRMC,202614.00,A,4227.5830,N,07116.0439,W,0.2,0.0,230316,,*27
GPS Epoch time at last PPS: 1458764774.00000 seconds
UHD Device time last PPS:   1458764774.00000 seconds
UHD Device time right now:  1458764774.24745 seconds
PC Clock time:              1458764774 seconds

Done!

What's going on here?  I think the newest UHD release is 3.9.3 so I could
try that but could there be some other issue?

Thanks for any help,

Devin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20160323/eb1d7fbe/attachment-0002.html>


More information about the USRP-users mailing list