[USRP-users] Failure to receive ACK packets

Yahia Shabara shabara.mail at gmail.com
Wed Mar 23 11:27:02 EDT 2016


Hello everybody,

I have implemented a simple network that uses packet based transmission and
I encountered a strange behavior that I hope you could help me understand.

The network consists of four nodes. Two of which are using packet feedback
(i.e. packet acknowledgment / negative ACK). Every time a data packet is
transmitted, the transmitter (TX) waits for an ACK packet to proceed with
the following packet transmission. If no ACK (or a NACK) is received, the
TX re-transmits the previous packet.

When the receiver sends the packet ACK immediately after the data packet is
successfully received, the ACK is never received by the TX.
 As a trial to solve this, I introduced a 50ms delay before the receiver
sends the ACK packet, only then the transmitter is able to receive the ACK.
I also tried to use two different USRPs; one as a transmitter and the other
as a receiver. As a result, I could make the communication work with only
10 ms introduced delay.

I cannot figure out why the delay solved the problem and I would really
appreciate your help.

I am using N210 rev4 USRPs and GNURadio
FW Version: 12.4
FPGA Version: 11.1
Along with SBXv3 daughter-board.

Output of uname -a is:
Linux yahia-ThinkPad-T430 3.19.0-25-generic #26~14.04.1-Ubuntu SMP Fri Jul
24 21:16:20 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I use gmsk modulation, with bit rate = 0.5Mbps and SPS = 2

Thanks,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20160323/7da54fc6/attachment-0002.html>


More information about the USRP-users mailing list