[USRP-users] USRP under run when when trying to send messages in a low rate

Marcus Müller marcus.mueller at ettus.com
Tue Mar 22 04:05:48 EDT 2016


Hi Damindra,

it's a bit too much guesswork involved if you don't share *what* kind of
application in GNU Radio you're designing. And a few parameters would be
helpful too: something like sampling rate of the USRP, which USRP type
you're using.

Generally, an underrun means your computer wasn't fast enough at
providing samples to your USRP.

Best regards,
Marcus

On 22.03.2016 04:06, Damindra Bandara via USRP-users wrote:
> Hi,
>
> I am creating an application using GNURadio that transmits a message
> every second. When I try to do this the transmit USRP indicates that
> is is under run and I was not able to recover the message at the
> receiving end.
>
> When I use the same setup to transmit a file it works fine and able to
> recover it.
>
> Is there any procedure that should be followed when transmitting
> infrequent messages? I appreciate if I could get any help.
>
> Thank you
> Damindra
>
> -- 
> Damindra Savithri Bandara,
> PhD in Information Technology (Candidate)
> George Mason University,
> Fairfax,
> Virginia
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20160322/203aecdc/attachment-0002.html>


More information about the USRP-users mailing list