[USRP-users] trouble with latest UHD under VirtualBox/Ubuntu

David Watt david.watt at sri.com
Tue Mar 15 11:32:30 EDT 2016


My system is Ubuntu 14.04.4 LTS, 64-bit, running as a guest under VirtualBox 5.0.16. My device is a B200. I've found that for whatever reason 2 recent UHD versions I've tried (UHD_003_009.003, UHD_003_010.??? from yesterday's git master) do not work for me. The symptom is that when running uhd_usrp_probe, after the fw hex file loads, the program fails, and the B200 does not show up under lsusb. After initial plug in, the B200 does show up under lsusb, but after uhd_usrp_probe and the fw load, the B200 is not shown under lsusb. Subsequent uhd_usrp_probe's all fail with no device type errors.

I think the issue is USB FX firmware associated, because after at one point I transitioned from UHD_003_008 to UHD_003_010, and rebooted the VM, and after the VM came up with UHD_003_010, the B200 (with the fw loaded) was visible under lsusb. Then when I ran uhd_usrp_probe it didn't say no device, it said firmware compatibility rev was 7 and it wanted 8. Then after power cycling it's visible again, but after UHD_003_010 loaded FX fw, it went to invisible again (to lsusb).

I'm OK with UHD_003_008 for now. It is able to connect more or less consistently as USB3 as reported by uhd_usrp_probe.

David Watt

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20160315/ca512712/attachment-0002.html>


More information about the USRP-users mailing list