[USRP-users] Running gr-foo examples wifi_rx

Tyler Hudgins tyler.hudgins at nvc-inc.net
Fri Mar 11 15:30:03 EST 2016


Hello all! I have have finally been able to get my usrp up and running
thanks to some help from the community here. I am now trying to test out
the wifi_rx.grc flow graph and some of the other examples provided with the
gr-foo/ieee-802.11 packages.

The first problem I am running across is the lack of packet capture into
wireshark. I can physically see the program running fine (or so I assume)
however I always seem to be left with malformed packets. Also for reference
I ran the loopback file and it worked perfect. My question here is how to I
achieve full packet capture/decoding?

The second issue that I have come across is that grc is no longer running
any of the files. I ran one of the files from the terminal and I am
thinking that it may be related because now I am only able to run any of
the .py and .grc files for gnuradio in the terminal as sudo. I am getting
the following error for all of my grc files now:


Showing:
"/home/tyler/gnuradio/gr-foo/build/gr-ieee802-11/examples/wifi_rx.grc"

Generating:
'/home/tyler/gnuradio/gr-foo/build/gr-ieee802-11/examples/wifi_rx.py'

Executing: /usr/bin/python2 -u
/home/tyler/gnuradio/gr-foo/build/gr-ieee802-11/examples/wifi_rx.py

linux; GNU C++ version 4.8.4; Boost_105400; UHD_003.010.git-156-g2d68f228

Using Volk machine: avx_64_mmx_orc
-- Detected Device: B200mini
-- Operating over USB 2.
-- Initialize CODEC control...
-- Initialize Radio control...
-- Performing register loopback test... pass
-- Performing CODEC loopback test... pass
-- Setting master clock rate selection to 'automatic'.
-- Asking for clock rate 16.000000 MHz...
-- Actually got clock rate 16.000000 MHz.
-- Performing timer loopback test... pass
-- Asking for clock rate 40.000000 MHz...
-- Actually got clock rate 40.000000 MHz.
-- Performing timer loopback test... pass
/tmp/ofdm.pcap: Permission denied
Traceback (most recent call last):
  File
"/home/tyler/gnuradio/gr-foo/build/gr-ieee802-11/examples/wifi_rx.py", line
303, in <module>
    main()
  File
"/home/tyler/gnuradio/gr-foo/build/gr-ieee802-11/examples/wifi_rx.py", line
297, in main
    tb = top_block_cls()
  File
"/home/tyler/gnuradio/gr-foo/build/gr-ieee802-11/examples/wifi_rx.py", line
194, in __init__
    self.blocks_file_sink_0 = blocks.file_sink(gr.sizeof_char*1,
"/tmp/ofdm.pcap", False)
  File
"/usr/local/lib/python2.7/dist-packages/gnuradio/blocks/blocks_swig0.py",
line 932, in make
    return _blocks_swig0.file_sink_make(*args, **kwargs)
RuntimeError: can't open file

>>> Done (return code -9)

-- 
Thanks,
Tyler Hudgins
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20160311/1dbe9b9b/attachment-0002.html>


More information about the USRP-users mailing list