[USRP-users] RFNoC image 2 bytes too large

Sam Carey sam at samcarey.com
Sun Mar 6 19:00:58 EST 2016


Howdy,

The "make X310_RFNOC_HGS" command is producing a “usrp_x310_rfnoc_fpga_HGS.bit” file that is 2 bytes too large:

$ uhd_image_loader --args="type=x300,addr=192.168.10.2" --fpga-path="usrp_x310_rfnoc_fpga_HGS.bit"
linux; GNU C++ version 4.8.4; Boost_105400; UHD_003.010.rfnoc-316-gb7546712

Error: RuntimeError: The specified FPGA image is too large: 15878034 vs. 15878032

I just switched from the rfnoc-devel branch to the rfnoc-radio-redo branch because I was recently forced to start using Vivado 2015.4 instead of 2015.2 (rfnoc-devel seems to not be compatible with 2015.4).
These are all the commands I ran prior to the above to set things up:

cd ~/GNURadio && \
git clone https://github.com/EttusResearch/uhd.git <https://github.com/EttusResearch/uhd.git> && \
cd uhd && \
git checkout rfnoc-radio-redo && \
git submodule init && \
git submodule update && \
cd fpga-src && \
git checkout rfnoc-radio-redo && \
cd usrp3/tools/scripts/ && \
source /tools/xilinx/vivado201504/Vivado/2015.4/settings64.csh ; \
sed -i '/VIVADO_BASE_PATH="/c\    VIVADO_BASE_PATH="/tools/xilinx/vivado201504/Vivado"' setupenv_base.sh <https://github.com/EttusResearch/fpga/blob/9f2f5e95c6d7d3a17861bd876d68b7ac7e33bbbe/usrp3/tools/scripts/setupenv_base.sh> && \
cd ../../top/x300/ && \
source setupenv.sh && \
make X310_RFNOC_HGS && \
cd build

Do you have any idea what’s going wrong?

Thanks,
Sam Carey
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20160306/75a3abd9/attachment-0002.html>


More information about the USRP-users mailing list