[USRP-users] Loading custom FPGA image on E310

Sergio Cruz Perez serchsype at hotmail.com
Fri Mar 4 15:36:10 EST 2016


Hi all,
I made a custom fpga image to test RFNoC for the E310. I copied the .bit file from my computer to the images directory in the E310 using  uhd_image_loader:
uhd_image_loader --args="type=e3x0" --fpga-path="/usr/local/share/uhd/images/usrp_e310_rfnoc_fpga.bit"  
Then I get the next message:
linux; GNU C++ version 4.9.2; Boost_105700; UHD_003.010.rfnoc-314-gf773e72b
-- Loading FPGA image: /usr/local/share/uhd/images/usrp_e310_rfnoc_fpga.bit... done
Then, when I run uhd_usrp_probe --init-only, the image that is loaded is the original one (usrp_e310_fpga_.bit):
-- Loading FPGA image: /usr/local/share/uhd/images/usrp_e310_fpga.bit... done-- Initializing core control...-- Performing register loopback test... pass
I tried rebooting the USRP after using uhd_image_loader but I get the same result.
What should I do to load my custom image?
Thanks
Sergio Cruz
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20160304/eb78a1c1/attachment-0002.html>


More information about the USRP-users mailing list