[USRP-users] problem with RFNoC tutorial on x310 with RIO connection;

Jonathon Pendlum jonathon.pendlum at ettus.com
Wed Oct 28 12:40:18 EDT 2015


Hi Yann,

Unfortunately RFNoC does not currently support the PCI express interface on
the X310. You have to use the 1 / 10 GigE interface.



Jonathon

On Wed, Oct 28, 2015 at 9:32 AM, Lecoq Yann via USRP-users <
usrp-users at lists.ettus.com> wrote:

> Hello,
>
> I am trying to follow the RFNoC "getting started" tutorial with my x310
> connected to a laptop with RIO interface and two UBX160 daughterboards.
>
> I believe I followed the whole procedure without any issue until the
> "uhd_usrp_probe --init-only" step. I then have the following error:
>
> linux; GNU C++ version 4.8.4; Boost_105400; UHD_003.010.rfnoc-285-gb9765c42
>
> -- X300 initialization sequence...
> -- Connecting to niusrpriorpc at localhost:5444...
> -- Using LVBITX bitfile
> /usr/local/share/uhd/images/usrp_x310_fpga_HGS.lvbitx...
> -- Setup basic communication...
> -- Loading values from EEPROM...
> -- Setup RF frontend clocking...
> -- Radio 1x clock:200
> -- Detecting internal GPSDO....
> UHD Error:
>     GPS invalid reply "", assuming none available
> No GPSDO found
> -- Initialize Radio0 control...
> -- Radio 0 Ctrl SID: 00:00>02:30
> Error: EnvironmentError: IOError: Radio ctrl (A) no response packet -
> AssertionError: bool(buff)
>   in uint64_t radio_ctrl_core_3000_impl::wait_for_ack(bool)
>   at
> /home/zbook_user/uhdRFNoC/uhd/host/lib/usrp/cores/radio_ctrl_core_3000.cpp:203
>
> I did a full power cycle of both the x310 and host and re-run the whole
> procedure from the beginning several time without success.
>
> The warning with the GPSDO doesn't seem to be a real problem (I do have a
> GPSDO board installed, but no antenna connected to it, which was never an
> issue with the "normal" FPGA image and uhd). The Radio error is of course
> much more problematic.
>
> Does someone has some idea what could be wrong in what I did ?
>
> Any help is greatly appreciated.
>
> Best regards,
>
> -Yann
>
>
>
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20151028/4784d5df/attachment-0002.html>


More information about the USRP-users mailing list