[USRP-users] USRP X310 Firmware update

Mike McLernon Mike.McLernon at mathworks.com
Sat Oct 24 12:05:46 EDT 2015


Hello Mostafa,

The versions of UHD on your host and your radio need to match.  I suspect that you are using R2014b of MATLAB, since that MATLAB version requires UHD 3.7.3.  

The support package does include UHD 3.7.3 in its distribution, but you need to change the UHD version on the radio to 3.7.3 as well.  You can use the sdruload function for that purpose.  See http://www.mathworks.com/help/supportpkg/usrpradio/ug/sdruload.html?searchHighlight=sdruload.

BTW, you do *not* want to build any version of UHD on your host machine.  The UHD binaries shipped with the support package should be all you need on the host.

Hth,
Mike


-----Original Message-----
From: USRP-users [mailto:usrp-users-bounces at lists.ettus.com] On Behalf Of Mostafa Hefnawi Gmail via USRP-users
Sent: Friday, October 23, 2015 11:51 PM
To: usrp-users at lists.ettus.com
Subject: Re: [USRP-users] USRP X310 Firmware update


> On Oct 23, 2015, at 7:10 PM, Mostafa Hefnawi Gmail <hefnawim at gmail.com> wrote:
> 
> Dear all;
> 
> I am trying to check the radio connection of USRP X310 using findsdru 
> under Matlab and I was asked to update radio firmware to version '003.007.003-vendor’. I did, but I am still getting the same warning.
> I am using Windows 7 with uhd_003.009.001-release_Win64_VS2013.
> I have tried to load uhd-images_003.009.001-release and uhd-images_003.007.003-release but still getting the same warning below.
> Thank you for your help.
> 
> ___________________________
> Checking radio connections...
> Warning: The firmware build for the USRP radio at '192.168.40.2' is 
> not compatible with the host code build. Update the USRP radio firmware to version '003.007.003-vendor'. Refer to Troubleshooting section of Getting Started document for instructions.
>> In warning at 7
>  In reportSDRuStatus at 41
>  In findsdru at 174
> 
> ans =
> 
>     Platform: 'X310'
>    IPAddress: '192.168.40.2'
>    SerialNum: 'F4A0C3'
>       Status: 'Not compatible'
> _________________________________________________
> 
> 


_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com


More information about the USRP-users mailing list