[USRP-users] Problem of setting up Rfnoc on E310

Philip Balister philip at opensdr.com
Thu Oct 22 14:30:33 EDT 2015


On 10/22/2015 11:14 AM, wwd via USRP-users wrote:
> Hi all,
> 
> I am trying to set up Rfnoc system on my E310. I followed this wiki
> https://github.com/EttusResearch/uhd/wiki/RFNoC:-Getting-Started
> 
> And I used this image for E310: sdimage-gnuradio-demo.direct.xz.
> 
> When I run command uhd_usrp_probe --init-only on E310, it passed, and I
> got these lines on the end:
> 
> linux; GNU C++ version 4.9.2; Boost_105700; UHD_003.010.rfnoc-0-unknown
> ........
> ........
> -- ========== Full list of RFNoC blocks: ============
> -- * 0/Radio_0
> -- * 0/Radio_1
> -- * 0/FIFO_0
> -- * 0/Window_0
> -- * 0/FFT_0
> -- Loading FPGA image: /usr/share/uhd/images/usrp_e310_fpga_idle.bit...
> done
> 
> But when run this command on host PC, I got this error:
> 
> linux; GNU C++ version 4.8.4; Boost_105400; UHD_003.010.rfnoc-285-gb9765c42
> 
> -- Initializing core control...
> -- Performing register loopback test... pass
> Error: RuntimeError: Currently only AXI transport supported with RFNOC
> 
> So it looks like I can not communicate with E310. Do I need to install
> XILINX ISE or VIVADO too?

RFNOC is only supported on the E310. It is not supported using network
mode and another computer.

Philip

> 
> Thanks,
> 
> Weidong
> 
> 
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com





More information about the USRP-users mailing list