[USRP-users] E310 u-blox GPS

Philip Balister philip at opensdr.com
Thu Oct 22 13:28:00 EDT 2015


On 10/22/2015 10:19 AM, Moritz Fischer via USRP-users wrote:
> Hi Jeff,
> 
> On Thu, Oct 22, 2015 at 9:34 AM, Jeff Tu via USRP-users
> <usrp-users at lists.ettus.com> wrote:
>> Hi,
>>
>> I recently got my hands on an E310, and I'm interested in checking out the u-blox GPS module on it. It seems to be connected to the processor through UART1, but I haven't found any resources about interfacing it (other than some u-blox manuals). I'm using the following SD image:
>>
>> http://files.ettus.com/e3xx_images/alpha/fido-rfnoc-test/sdimage-gnuradio-dev.direct.xz
>>
>> I noticed at the end of the boot there's a message that say:
>>
>> $ /dev/ttyPS1 identified as a u-blox 7.03 (45969) at 9600 baud.
>>
>> Does anyone have a started application to do some basic initialization, configuration, etc.?
> 
> You can use gpsd's API to talk to it, example applications to view the
> output are gpsmon, cgps, ...
> If you give use a bit more background on what you're trying to do it's
> easier to point you in the right direction.

Also, with an antenna connected to the gps port, run ntpq -p. Hopefully
the time is synced to gps. All these features are in the test image, not
the image that comes with the unit.

Philip

> 
> Cheers,
> 
> Moritz
> 
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
> 





More information about the USRP-users mailing list