[USRP-users] Problem of an simple example on E310

wwd_usrp wwd_usrp at hotmail.com
Wed Oct 14 22:55:30 EDT 2015


Hi all,

I am a new user of E310.

I installed previously the UHD version 3.10.0 on my Ubuntu 14.04, but in 
order to match with E310, I installed the version 3.8.4 from the 
sources. I can receive correct response with the correct IP addr when I 
send commands: uhd_find_devices and uhd_usrp_probe.

Now I want to test it with some simple example. I tried an example in  
uhd-3.8.4/examples/init_usrp. After compile, I tried to run ./init_usrp 
--args="addr=192.168.10.2", it gave me an error like this:

wwd at wwd-lessena:~/ettus_files/uhd-3.8.4/examples/init_usrp/build$ 
./init_usrp --args="addr=192.168.10.2"
linux; GNU C++ version 4.8.4; Boost_105400; UHD_003.010.git-38-gc77ffb3e


UHD Warning:
     Unable to set the thread priority. Performance may be negatively 
affected.
     Please see the general application notes in the manual for 
instructions.
     EnvironmentError: OSError: error in pthread_setschedparam

Creating the usrp device with: addr=192.168.10.2...
Error: LookupError: KeyError: No devices found for ----->
Device Address:
     addr: 192.168.10.2


The IP addr is correct. I don't know why it cannot find the device. I 
mentioned the UHD version was still 3.10, how could I uninstall this 
version?

Thanks

Weidong Wang
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20151014/767c640c/attachment-0002.html>


More information about the USRP-users mailing list