[USRP-users] USB problems

Vsr Ravi vsr_ravi at yahoo.com
Tue Jul 28 17:31:56 EDT 2015


Hi,Thanks for the suggestions that you have given. But I have encountered a problem. Whenever I run the file of Latency_test located in /usr/lib/uhd/examples, I get the error as
Error: LookupError: IndexError: multi_usrp::mb_root(140725369489696) - vector::_M_range_check

And when I run "test_messages" command, it shows 
Segmentation fault (core dumped)

Please suggest as to what I can do to prevent the above errors. Thank you 
Regards,Ravi
 


     On Tuesday, 28 July 2015 4:28 AM, Marcus Müller <marcus.mueller at ettus.com> wrote:
   

  Hi Ravi,
 
 On 28.07.2015 00:55, Vsr Ravi wrote:
  
      Hey all, I have tried to run the USRP1 by giving the command "sudo uhd_usrp_probe and I get the result as below. 
   linux; GNU C++ version 4.8.4; Boost_105500; UHD_003.009.git-144-g407e3086 
  -- Opening a USRP1 device... -- Loading FPGA image: /usr/local/share/uhd/images/usrp1_fpga.rbf... done       
 ... 
       
  Can anyone please tell what this means and what do I do next as I am new to gnuradio. Thanks       
 As Martin said: Both your USRP as your UHD installation work pretty well!
 The only thing is that you need to run it as root (the sudo part), and that's not a good thing.
 Can you make sure that /etc/udev/rules.d/ contains the uhd.rules file[1]? If not, copy it over from /usr/local/lib/uhd/utils/uhd-usrp.rules, e.g. like
 sudo cp /usr/local/lib/uhd/utils/uhd-usrp.rules /etc/udev/rules.d/
 
 and then reboot.
 
 The next time you plug in your USRP, it should no longer be only accessible by root.
 
 Best regards,
 Marcus
 
 [1] You said earlier you did
 cd usr/lib/uhd/utils
sudo cp uhd-usrp.rules /etc/udev/rules.d/
sudo udevadm control --reload-rules
sudo udevadm trigger but that's not the right path, if uhd is installed to /usr/local/...
 
 

  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150728/7f96766a/attachment-0002.html>


More information about the USRP-users mailing list