[USRP-users] USB problems

Marcus Müller marcus.mueller at ettus.com
Sat Jul 25 11:56:42 EDT 2015


Dear Ravi,

that path was just an example. However, where you look was the GNU Radio 
build directory, not the UHD build directory.
You will have to take a look at the CMakeCache.txt in the UHD build 
directory.

Best regards,
Marcus

On 25.07.2015 17:48, Vsr Ravi wrote:
> Hi Marcus,
> I have the CmakeCache.txt in /home/gnuradio/build folder but not in 
> the specified one as you have mentioned. And also, I don't see the 
> line ENABLE_USRP1:BOOL=OFF. Do i need to add the line specifically 
> anywhere or do I need to rebuild UHD completely? Please help .
>
> Regards,
> Ravi
>
>
>
> On Saturday, 25 July 2015 1:01 AM, Marcus Müller 
> <marcus.mueller at ettus.com> wrote:
>
>
> Hello Ravi,
> this is good:
>> Bus 001 Device 010: ID fffe:0002 
> so your PC's operating system detects it.
>
> When you built UHD, did it say that USRP1 was enabled?
> If you can't remember, go to where you've built uhd, e.g. 
> /home/vsrravi/uhd/host/build, and open the CMakeCache.txt.
> Search for ENABLE_USRP1 ; you should find a line like
> ENABLE_USRP1:BOOL=OFF
>
> Best regards,
> Marcus
>
> On 07/25/2015 01:01 AM, Vsr Ravi wrote:
>> Hello Marcus,
>> I have built uhd myself . And the output of sudo lsusb before i 
>> connect is
>>
>> Bus 001 Device 006: ID 0c45:64ad Microdia
>> Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 
>> Card Reader Controller
>> Bus 001 Device 004: ID 04f3:0034 Elan Microelectronics Corp.
>> Bus 001 Device 007: ID 0cf3:0036 Atheros Communications, Inc.
>> Bus 001 Device 008: ID 04ca:0061 Lite-On Technology Corp.
>> Bus 001 Device 002: ID 8087:8000 Intel Corp.
>> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>> Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
>> Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>> ravi1991 at ravi1991-Inspiron-5537:~$
>>
>> sudo lsusb after i connect is given below
>>
>> Bus 001 Device 006: ID 0c45:64ad Microdia
>> Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 
>> Card Reader Controller
>> Bus 001 Device 004: ID 04f3:0034 Elan Microelectronics Corp.
>> Bus 001 Device 007: ID 0cf3:0036 Atheros Communications, Inc.
>> Bus 001 Device 008: ID 04ca:0061 Lite-On Technology Corp.
>> Bus 001 Device 010: ID fffe:0002
>> Bus 001 Device 002: ID 8087:8000 Intel Corp.
>> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>> Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
>> Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>>
>> So what can be the problem my device not being found. lsusb is 
>> working and is detecting usb port connected to usrp.
>>
>> Thanks
>>
>>
>>
>>
>>
>> On Friday, 24 July 2015 5:44 PM, Marcus Müller 
>> <marcus.mueller at ettus.com> <mailto:marcus.mueller at ettus.com> wrote:
>>
>>
>> Hello!
>>
>> That looks right so far. Does running
>>
>> lsusb
>>
>> before and after you connect the USRP show a difference?
>> You're looking for a device with the vendor/product ID 04B4:8613 or 
>> FFFE:0002.
>>
>> Did you build that UHD yourself or did you install it as a binary?
>>
>> Best regards,
>> Marcus
>>
>> Am 25. Juli 2015 00:18:43 MESZ, schrieb Vsr Ravi via USRP-users 
>> <usrp-users at lists.ettus.com> <mailto:usrp-users at lists.ettus.com>:
>>
>>     Hi all,
>>     I have tried connecting my USRP to my laptop via USB cable. But
>>     anything is not being detected even though i type in sudo
>>     "uhd_find_devices". It says
>>
>>     linux; GNU C++ version 4.8.4; Boost_105500;
>>     UHD_003.009.git-144-g407e3086
>>
>>     No UHD Devices Found
>>
>>      I have also used this command below. But I have not seen any
>>     difference. Is there a problem with anything. I am using USRP1.
>>     Should I rewrite any udev rules? or is the UHD installation is
>>     not latest or not properly done?  Please reply ASAP.
>>
>>     Thank you very much.
>>
>>     cd usr/lib/uhd/utils
>>     sudo cp uhd-usrp.rules /etc/udev/rules.d/
>>     sudo udevadm control --reload-rules
>>     sudo udevadm trigger
>>
>>     ------------------------------------------------------------------------
>>
>>     USRP-users mailing list
>>     USRP-users at lists.ettus.com <mailto:USRP-users at lists.ettus.com>
>>     http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>>
>>
>> -- 
>> Sent from my Android device with K-9 Mail. Please excuse my brevity.
>>
>>
>
>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150725/d7f69004/attachment-0002.html>


More information about the USRP-users mailing list