[USRP-users] E310 stuck at "Loading FPGA image: /usr/share/uhd/images/usrp_e310_fpga.bit..."

Philip Balister philip at opensdr.com
Wed Jul 15 14:42:04 EDT 2015


On 07/15/2015 01:05 PM, Collins, Richard via USRP-users wrote:
> Hello,
> 
> I am trying to get the E310 working (not in network mode) to run some
> examples. I first unxz'd the release 2 dev image from
> http://files.ettus.com/e3xx_images/e310-release-002/ .  (I'm not sure the
> difference between demo and dev... I'll try it with demo next...), and then
> used dd to flash it to an sdhc class-10 microsd card that's greater than
> 8GB.

Demo is the dev image with an X server and a few more programs.

Bmaptool will let you right images to cards faster:

http://gnuradio.org/redmine/projects/gnuradio/wiki/Copy_an_image_file_to_the_SD_card

> 
> We then were able to set up ssh by changing the sshd.conf file as described
> toward the very end of the USRP E3x0 manual.
> 
> Logged in via ssh -X root@<E310's IP>, we are able to launch RTIMULibDemo
> and gnuradio-companion, each successfully.
> 
> Problem A: Whether we try to load a python example from
> /usr/share/gnuradio/examples/uhd/ OR build a simple example for GRC (that
> uses either a UHD source or sink), the build/run process gets stuck at
> "Loading FPGA image: /usr/share/uhd/images/usrp_e310_fpga.bit...", hangs
> and never quits or continues.
> 


Can you try uhd_usrp_probe? Let's get the fpga loading reliably before
working on your other problem.

Philip

> Problem B: I don't know how to correctly address the E310 from either
> within GRC on the zynq, or from GRC on a laptop. While ssh'd into the E310
> and running GRC locally, or with the E310 on the same subnet as a host
> computer over a direct ethernet connection and running GRC on the host
> computer... nothing seems to work no matter if we leave Device Address or
> Device Arguments alone, or put something in either field (ip address in
> Device Address field or any of the following in the Device Arguments field
> "addr=192.168.0.10" (or "addr=127.0.0.1" when running locally) or
> "serial=308E670"). In this case, the process hangs before trying to load
> the fpga.bit file.
> 
> 
> Some further information:
> 
> root at ettus-300:~# uname -a
> Linux ettus-e300 3.14.2-xilinx #1 SMP PREEMPT Tue Apr 21 06:51:07 EDT 2015
> armv7l GNU/Linux
> root at ettus-300:~# uhd_find_devices
> 
> linux; GNU C++ version 4.9.1; Boost_105600; UHD_003.008.004-0-unknown
> 
> ------------------------------
> 
> --UHD Device 0
> ------------------------------
> 
> Device Address:
> 
> type: e3x0
> 
> node: /dev/axi_fpga
> 
> name:
> 
> serial: 308E670
> 
> product: 30674
> 
> 
> Any help would be appreciated!
> 
> Thanks,
> 
> Richard Collins
> 
> 
> 
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
> 





More information about the USRP-users mailing list