[USRP-users] Urgent Help Needed

Marcus Müller marcus.mueller at ettus.com
Thu Jul 9 11:26:36 EDT 2015


Hi Prabhu,
> I am using USRP E-310. It has an embedded OS.
Exactly! That means that it's not designed to run just any software, but
only the software you specifically compiled for it.

Hence, you typically use a SDK on a PC to compile software for the E310,
and build a filesystem image (to write it to the SD card) from that.

> This device cannot be operated in Network Mode. And because of this
> some we need have the functionality of installing the missing library
> files. 
Good approach! The Network Mode is really just a diagnostic tool.
Otherwise, you could buy a B210 for a lot less money to get the same
functionality via USB (minus the better filtering on the E310).
> SCIPY and NUMPY stack of python is heavily needed for some signal
> processing and other math operations if I am writing a python script.
numpy is included in the current release [1]. I think there was so
problem with scipy's support on the arm platform; maybe someone can
comment on that.

> I tried to install the LAPACK library from source but new issues crops
> up saying gfortran command not found.
gfortran is a fortran compiler, LAPACK is implemented in Fortran90.
That's something you very definitely don't want to install on your
embedded platform.

So the solution would be getting Lapack, scipy, and all the tools you
need into your modified SD card image. You need to download the SDK from
[2].

Best regards,
Marcus

[1]
http://files.ettus.com/e3xx_images/e310-release-002/oecore-x86_64-armv7ahf-vfp-neon-toolchain-nodistro.0.manifest
[2]
http://files.ettus.com/e3xx_images/e310-release-002/oecore-x86_64-armv7ahf-vfp-neon-toolchain-nodistro.0.sh

h

On 07/09/2015 03:58 PM, prabhu via USRP-users wrote:
> Hi all,
> I am using USRP E-310. It has an embedded OS. But this has very
> limited functions. I am not able to install the SCIPY stack. I am not
> able to complete it because of the warning which says "LAPACK" missing.
> This device does not have package repository similar to other linux
> operating systems. Only way I can install a new package is through
> OPKG which also missing basic libraries.
>
> This device cannot be operated in Network Mode. And because of this
> some we need have the functionality of installing the missing library
> files.
>
> SCIPY and NUMPY stack of python is heavily needed for some signal
> processing and other math operations if I am writing a python script.
>
> I tried to install the LAPACK library from source but new issues crops
> up saying gfortran command not found. If any one faced the same issue
> and have a solution do share with me.
>
>
>
>
>  
> *-------------------------------------------------------------------------------------------------------------------------------------
> *
> *Thanks,
>
> *
> *Prabhu Janakaraj*
>
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150709/35a291cf/attachment-0002.html>


More information about the USRP-users mailing list