[USRP-users] Can ping but not find_device on N210

Marcus Müller marcus.mueller at ettus.com
Mon Jul 6 09:24:09 EDT 2015


Hi Aaron,

the situation is the following: your PC is in a different subnet than
your USRP, hence the USRP doesn't know where to send packets to your PC
directly, and tries to send them to the configured default gateway.
Probably, this doesn't work either (that gateway probably doesn't exist).

The easiest solution to this is giving your PC an IP address from the
same subnet, e.g. if you're on linux, a

sudo ip address add 192.168.10.100 dev eth0

(assuming eth0 is the network interface you want to use)

Then, add a route through that:

sudo ip route add 192.168.10.0/24 dev eth0

to tell your computer that all packets for any address in the
192.168.10.* network should directly go through eth0.

Best regards,
Marcus

On 07/06/2015 02:31 PM, Aaron Henderson wrote:
> Hotmail was telling me it wasn't sending, but obviously it was.
>
> uhd_usrp_probe offers the same error, and my PC's IP address is set to
> 10.51.14.35.
>
> Aaron
>
> ------------------------------------------------------------------------
> Date: Wed, 1 Jul 2015 18:49:11 +0200
> To: usrp-users at lists.ettus.com
> Subject: Re: [USRP-users] Can ping but not find_device on N210
> From: usrp-users at lists.ettus.com
>
> Hi Aaron,
> I got your mail four times, so maybe there's something wrong with your
> mail server?
>
> Does
>
> uhd_usrp_probe --args "addr=192.168.10.2"
>
> work?
> What is your PC's IP address?
>
> Best regards,
> Marcus
>
> On 07/01/2015 04:24 PM, Aaron Henderson via USRP-users wrote:
>
>     Hello again list,
>
>     I am in a different part of my project and am running into an
>     issue with finding my device.
>
>     I have found multiple listings on the Internet about this issue
>     but it is all overwhelming. Meaning I am not sure which
>     information will be beneficial to me or not.
>
>     The steps I have taken so far are:
>     1. I have pinged the device and it is communicating with the computer.
>     2. I have ran uhd_find_devices and uhd_usrp_probe(with and without
>     the IP address as an arguement), for uhd_find_devices I get this
>     error message, 'No UHD Devices Found', and for uhd_usrp_probe I
>     get this error message,
>     'Error: LookupError: KeyError: No devices found for ----->
>     Device Address:
>         addr: 192.168.10.2'
>     3. I have disabled my firewall and still the same issue persists.
>     4. I have started in safe mode and still the same issue persists.
>
>     Can someone point me to a reliable webpage with a similar issue if
>     it exists, or give me some pointers?
>
>     Aaron
>
>
>     _______________________________________________
>     USRP-users mailing list
>     USRP-users at lists.ettus.com <mailto:USRP-users at lists.ettus.com>
>     http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>
>
> _______________________________________________ USRP-users mailing
> list USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150706/463262a9/attachment-0002.html>


More information about the USRP-users mailing list