[USRP-users] Error when install UHD driver for USRP B210

Marcus Müller marcus.mueller at ettus.com
Sat Jul 4 03:57:57 EDT 2015


Hi Tran Phi,

I already replied to you yesterday -- maybe my mail ended up in the Spam
folder?
> Hi Tran Phi,
>
> it's absolutely essential that you uninstall all UHD packages coming
> directly from Ubuntu, as these old versions will conflict with the new
> version:
>
> sudo apt-get remove uhd-host
>
> Note that all the packages that Ubuntu ships (e.g. GNU Radio) that
> rely on UHD will be removed -- there's no way around that, because
> they were built using Ubuntu's prehistoric version, and can't work
> with the current UHD. You will need to rebuild these packages from
> source code yourself.
>
> Luckily, there's help with that. So after you've installed UHD from
> the Ettus repositories, go to http://pybombs.info and follow the
> instructions there to get GNU Radio and related software.
>
> Best regards,
> Marcus

Hope this one reaches you,
Marcus


On 07/04/2015 06:30 AM, Tran Phi via USRP-users wrote:
> Hi everybody !
>
> I've received a board USRP B210 and tries to install the UHD driver
> for it.
> I follow the steps:
> sudo apt-get install libuhd-dev libuhd003 uhd-host
> sudo bash -c 'echo "deb http://files.ettus.com/binaries/uhd/repo/uhd/ubuntu/`lsb_release <http://files.ettus.com/binaries/uhd/repo/uhd/ubuntu/lsb_release> -cs` `lsb_release -cs` main" > /etc/apt/sources.list.d/ettus.list'
> sudo apt-get update
> sudo apt-get install -t `lsb_release -cs` uhd
>
> But i always meet the error when run the last command: 
>
> root at dcn-desktop:/opt/OAI/UHD/uhd/host/build/examples# sudo apt-get
> install -t `lsb_release -cs` uhd
> Reading package lists... Done
> Building dependency tree      
> Reading state information... Done
> The following NEW packages will be installed:
>   uhd
> 0 upgraded, 1 newly installed, 0 to remove and 13 not upgraded.
> Need to get 29.5 MB of archives.
> After this operation, 137 MB of additional disk space will be used.
> WARNING: The following packages cannot be authenticated!
>   uhd
> Install these packages without verification? [y/N] y
> Get:1 http://files.ettus.com/binaries/uhd/repo/uhd/ubuntu/trusty/
> trusty/main uhd amd64 003.008.000-release [29.5 MB]
> Fetched 29.5 MB in 8s (3,341
> kB/s)                                            
> (Reading database ... 198639 files and directories currently installed.)
> Preparing to unpack .../uhd_003.008.000-release_amd64.deb ...
> Installing UHD.
> Unpacking uhd (003.008.000-release) ...
> dpkg: error processing archive
> /var/cache/apt/archives/uhd_003.008.000-release_amd64.deb (--unpack):
>  trying to overwrite '/usr/share/man/man1/usrp2_card_burner.1.gz',
> which is also in package uhd-host 3.5.5-1
> dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
> Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
> Errors were encountered while processing:
>  /var/cache/apt/archives/uhd_003.008.000-release_amd64.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> does anybody have the experice with this problem ?
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150704/abec9ae3/attachment-0002.html>


More information about the USRP-users mailing list