[USRP-users] Some general help

Michael Kuplicki - US mkuplicki at caci.com
Wed Jul 1 13:22:05 EDT 2015

Hello Neel,

That was good advice.  I added  @MYGROUP  - rtprio   99   to    /etc/security/limits.conf  and that took care of the lockup problem after running tx_samples_from_file.    I still have the problem with not always seeing the B200 after a power up.  When I run uhd_find_devices I get the loading firmware message but sometimes after that a no devices found message.  Although I have been using the RPi for my work, another coworker that used this B200 before me said he saw the same behavior.  He saw this with his  desktop and laptop.  In his experience after the device is found everything is solid.  This may be a problem particular to this board.   Is it possible to update the onboard firmware in the B200?



From: Neel Pandeya [mailto:neel.pandeya at ettus.com]
Sent: Monday, June 29, 2015 7:14 PM
To: Michael Kuplicki - US
Cc: usrp-users
Subject: Re: [USRP-users] Some general help

Hello Michael Kuplicki:
There's some documentation at the link below for how to address the UHD warning that you're seeing.

I agree with Marcus Müller, what you are seeing is a bit strange. The B200 should still be able to operate over USB 2.0 with the RPi. Be careful that you're not overwhelming the RPI. Perhaps use a very low rate such as ~500 ksps. Could you try running your B200 with an laptop, preferably with Ubuntu 14.04, with USB 3.0, to verify that the board is working correctly? Also, I would recommend that you avoid using the master and maint branches of UHD, and that you stick to using tagged releases of UHD, such as 3.8.4.


On 29 June 2015 at 14:54, Marcus
Müller <usrp-users at lists.ettus.com<mailto:usrp-users at lists.ettus.com>> wrote:
Hi Mike,

that's all a bit strange; especially the part where you have to reset the device a couple of times -- after a loss of power, the device is pretty much in a clean slate status.
So, as a first test, I'd just ask you to try your USRP with your "proper" PC, and see if it works normally. The rates you can push through USB2 might still be a bit hard on the poor raspbi.

Best regards,
On 06/29/2015 11:19 PM, Michael Kuplicki - US via USRP-users wrote:
I am running Ubuntu Mate 15.04 on a Raspberry Pi 2.  I am trying to run a B200 USRP with this setup, mostly interested in transmitting with the B200.  I have been successful in building the uhds and have been able to transmit a FM signal I created the IQ data with in Matlab.  My problem is that after running  tx_samples_from _file to transmit my data it may not work again.  tx_samples_from_file seems to run the second time on the terminal  but the transmit LED does not come on and no RF signal is generated.  I also find that connecting to the device is problematic.  uhd_find_devices does not always work after a power up reset.  I have to reset the hardware with a power cycle a few times before it will take.  The Raspberry Pi does not have a USB 3.0 port.  I have tried using external power to the B200 but the behavior does not seem to change.  And when running tx_samples_from _file  I get two startup messages:

linux; GNU C++ version 4.9.2; Boost_105500; UHD_003.009.git-171-g51bc00ee

UHD Warning:
    Unable to set the thread priority. Performance may be negatively affected.
    Please see the general application notes in the manual for instructions.
    EnvironmentError: OSError: error in pthread_setschedparam

Any suggestions?


USRP-users mailing list

USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>


USRP-users mailing list
USRP-users at lists.ettus.com<mailto:USRP-users at lists.ettus.com>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150701/5e3abfad/attachment-0002.html>

More information about the USRP-users mailing list