[USRP-users] USRP B210 , Underflow and late packets.

Younes KHADRAOUI younes.khadraoui at telecom-bretagne.eu
Thu Apr 30 11:31:53 EDT 2015


Hello community,

I'm trying to use the USRP B210 with some software (OpenAirInterface for who might know). However, I'm getting a lot of underflow ('U' printed) and late packets ('L' printed). My machine is quite powerful: Intel Xeon with 6 physical cores at 3.8Ghz. I have the latest release of UHD. I also disabled all power management features in the BIOS and in the kernel as well (C-States, Intel SpeedStep, Hyperthreading). All of these could not make it work. The weird thing is that I tried it in a older machine (Intel Xeon with 4 physical cores at 3.4Ghz) and it worked this time. I was thinking that it might be a USB controller issue since it is the only difference I can see between the two machine: the one with the Intel Corporation Wellsburg USB xHCI Host Controller does not work while the one with the Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI worked. 

Or maybe it is another power management feature that needs to be disabled. However, I can not see anything else. If anybody has an idea about this, or can confirm that the Intel Corporation Wellsburg controller has issues with the UHD driver. Any help is appreciated. 

-- 
Younes Khadraoui
PhD Student, Network Security and Multimedia Department.
IRISA/Telecom Bretagne.




More information about the USRP-users mailing list