[USRP-users] Upgrading to UHD

Ian Buckley ianb at ionconcepts.com
Tue Apr 28 19:13:00 EDT 2015


James,
USRP2's were a little fussy about SD Cards. I hang onto a stock of the Kingston 2G cards that were the normal factory type and worked well. I've had less success with brands like PNY, and 2G is so hard now to get from anyone credible, I suggest you reuse your original SDCARD with new images. Last time I checked (a while) Ettus still had some SDCard's in inventory .

It is possible that the previous user has changed the IP address, and maybe the usrp2_recovery tool is struggling to work correctly with such old firmware on the original SD Card? If you are network savy wireshark might give you some clues, you may see broadcast packets after you turn on the USRP that give the IP address away.

You can use dd to take a backup image of your SD card before loading new images onto it if you are feeling extra paranoid.

-Ian


On Apr 28, 2015, at 12:12 PM, "Dolan, James T. (US SSA) via USRP-users" <usrp-users at lists.ettus.com> wrote:

>  
>  
> From: Dolan, James T. (US SSA) [mailto:james.t.dolan at baesystems.com] 
> Sent: Tuesday, April 28, 2015 3:08 PM
> To: usrp-users at lists.ettus.com
> Subject: Upgrading to UHD
>  
> To Whom it May Concern –
> I am attempting to use a USRP2 with the UHD drivers and am unable to establish an Ethernet connection between the unit and the host.  The unit is a rev. 4, with a WBX daughterboard.  It was last known to work with a raw Ethernet (libusrp driver) setup and a host running Ubuntu 10, but that host machine is not available so I do not know any details of the configuration.  I am currently working with a host running Ubuntu 14.04.  The Ethernet interface is an Intel 82566MM Gigabit Network, and I have it configured with a static IP address of 192.168.10.1.  The firewall is disabled.
> With the SD card that was in the unit when it was last being used, the behavior of the LEDs at startup appears to be correct – all flash, D & F stay lit, and the green LED at the Ethernet connector is dimly lit.  However, I get no result pinging any IP address from 192.168.10.0 - .255.  Running usrp2_recovery.py does not return any errors, but it does not appear to set the IP address on the USRP2, as it still does not respond to a ping at the new address.  I then attempted to use a new SD card.  The card used was a PNY P-SD2GB-EF 2 GB, Class 4 card.  Using usrp2_card_burner_gui.py, I put the files usrp2_fpga.bin and usrp2_fw.bin on the card, and tried to use it but the unit was even less responsive than before – the only LED that lit was F.
> Please advise.
> JimD
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150428/1c778109/attachment-0002.html>


More information about the USRP-users mailing list