[USRP-users] Sync issue between the two TX channels of X310

Michael West michael.west at ettus.com
Fri Apr 24 08:58:40 EDT 2015


Hi Carel,

Yes, the X310 has an internal PPS.  So, just set the time source to
"internal" and call set_time_unknown_pps() and you should be fine.

Regards,
Michael

On Fri, Apr 24, 2015 at 2:48 AM, Carel Combrink <carel.combrink at gmail.com>
wrote:

> Hi Michael,
>
>
>> To be clear, set_time_now() will cause the VITA times on the 2 radios of
>>> the X310 to be different and is most likely the cause of the
>>> synchronization issue.  You must use set_time_next_pps() or
>>> set_time_unknown_pps() to ensure the times are the same.  It is highly
>>> recommend to use set_time_unknown_pps() as it takes additional steps to
>>> make sure the times are synchronized.
>>>
>>
>>
>
> Is there a way to synchronise the 2 radios without an external PPS? Is
> there an internal PPS available to the daughter-boards when the clock is
> set to "internal" on the mother-board? Or can we simulate something like
> this?
>
> We do have the Board Mounted GPSDO installed if that might help at all.
>
> We have solved the problem before as mentioned with the OctoClock, but the
> OctoClock is not available any more, and using the OctoClock to sync 2
> radios on the same device is overkill.
>
> Regards,
> Carel
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150424/0a7b37f5/attachment-0002.html>


More information about the USRP-users mailing list