[USRP-users] Cannot find usrp e310 with uhd_find_devices

Ivan sdsr10 at yahoo.com
Fri Apr 24 06:32:09 EDT 2015


I managed to make some progress thanks to the tips from Marcus and Neel. I modified slightly the build-gnuradio script to take -DENABLE_E300=ON option in the uhd build function and then I built everything again on the host PC. 
The E310 USRP is connected directly to the PC with a cross-over ethernet cable and has a static IP address.I can now detect the E310 from the PC using uhd_find_devices after I turn on the network mode on the E310. However, I still cannot run uhd_fft. When I ran it for the first time I got the error message: "Runtime error: Expected FPGA compatibility number 6.x but got 4.0. The FPGA build is not compatible with the host code build" 
I copied the usrp_e310_fpga.bit file from /usr/local/share/uhd/images on the PC to /usr/share/uhd/images on the E310 using scp. The old bit file was replaced but I still kept a copy of it in a separate directory. I ran uhd_fft again and this time I got a different error message: "e300_remote_codec_ctrl_impl transaction failed".
Do I still have the compatibility problem or is it something else?
Ivan 
      From: Neel Pandeya <neel.pandeya at ettus.com>
 To: Ivan <sdsr10 at yahoo.com> 
Cc: "usrp-users at lists.ettus.com" <usrp-users at lists.ettus.com> 
 Sent: Wednesday, 22 April 2015 4:58 AM
 Subject: Re: [USRP-users] Cannot find usrp e310 with uhd_find_devices
   
Hello Ivan:

I assume you're trying to run "uhd_find_devices" on the external host, running Ubuntu 14.04. You need to have Network Mode enabled on your E310, and you also need to build UHD on the external host with E310 support. By default, E310 is not enabled when you build UHD. To enable E310 support, add "-DENABLE_E300=ON" as an option when you invoke cmake. Please see the links below.

http://files.ettus.com/manual/page_usrp_e3x0.html#e3x0_network_mode

http://files.ettus.com/manual/page_usrp_e3x0.html#e3x0_sdk_usage_uhd

--Neel



On 20 April 2015 at 22:44, Ivan via USRP-users <usrp-users at lists.ettus.com> wrote:



Hi, 

I've recently started using an E310 USRP. I want to use some GNU radio examples to generate and receive waveforms but the device is not being detected. I can log on using both the console and ethernet port. I've configured the usrp to use a static IP address and set it to 192.168.10.3. I can access this address through ssh and pinging it also sends replies back. However, running uhd_find_devices does not work. I get "no uhd devices found". Even when I specify the address with uhd_find_devices --args="addr=192.168.10.3", I still don't get anything. 
I use Ubuntu 14.04. I've installed gnuradio and uhd using the gnuradio build script. When I run uhd_find_devices or uhd_fft, the uhd version that comes out is UHD_003.008.003-137-g2f760ac0. I've also tried disabling the firewall with sudo ufw disable, but that makes no difference. What else should I do?
Regards,Ivan
 
_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com





  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150424/b3b13712/attachment-0002.html>


More information about the USRP-users mailing list