[USRP-users] B200 Broadcast FM and other signals on airband

Paul B paulanthonybrown at hotmail.co.uk
Thu Apr 23 16:43:48 EDT 2015


Hi Marcus,

Thank you for your advice and the explanation of the HDSDR/UHD incompatability.

Regarding the tuning, i believe that my centre frequency is 122.590MHz, and i can tune to +/- 8MHz either side of that. I’m not completely sure though, as i’m still rather new to the whole SDR scene, and the B200 is my first major SDR since using the RTL Dongles. 

I’ve managed to, i think, narrow down the problem to the computer i’m using. I tried the B200 on my partners laptop, plugging it in, installing Balints ExtIO package, zadig driver and libusb0 and it seemed to work fine. No ghost signals at all. Admittedly it was using USB 2, but even when using USB 2 on my main computer, i was still getting ghost signals. 
The computer i use the B200 with is running the USB 3.0 Intel eXtensible host controller, which i believe is compatible with the B200 series, and i’ve done a complete fresh install of Windows 8.1, installing Balints package, and using the zadig driver only, so i can’t see the error being within Windows. 

I’ve also noticed they appear even with rather low gain, but only within 110MHz – 135MHz region. I’ve not seen any signals above that, that shouldn’t be there.

Paul

From: Marcus Müllervia USRP-users 
Sent: Thursday, April 23, 2015 7:27 PM
To: usrp-users at lists.ettus.com 
Subject: Re: [USRP-users] B200 Broadcast FM and other signals on airband

Hi Paul, 

sorry to hear you're still in trouble; I'll try my best to help you, though HDSDR and Windows are really not my forte.
Balint is currently not in office, so I can only give you my piece of insight:

first of all, I'm a bit confused; your settings say you've got a sampling rate of 16MS/s, and your center frequency is 120.8MHz, so your observable spectrum should be 112.8MHz - 128.8MHz. However, HDSDR's waterfall shows different frequency limits -- maybe there's some sweeping or caching, or is maybe my definition of tuning and LO frequency different from that of HDSDR?

I can, however, explain the incompatibility warning: HDSDR is linked against a specific version of UHD, and can only work with exactly that version of the UHD.dll, which is why Balint packages it with the whole Extio framework. Installing a more modern version of UHD system-wide doesn't help you, here, since HDSDR continues to use the packaged UHD.dll. Thus, after installation of UHD and flashing of the images, you've got "modern" FPGA and firmware on your B200, and "old" UHD talking to the device -- which is what the error complains about.

Regarding your ghost signals: Those are interesting, though, if I read that correctly, they are at -82dB, which is relatively little, considering your 27dB gain. Can you try to disable AGC? If that's not enough, my first guess would be to play around with gain: Too much gain leads to spectral images[1], too little gain together with AGC might over-emphasize spurs.

Greetings,
Marcus

[1] If you have a strong signal, and high gain, your amplifier, being composed of nothing more than transistors, goes into saturation; the transmission function then is no longer practically output = input * gain (), but gets a quadratic term (); now using the some properties of the trigonometric functions, in this case  applied to an input signal , you'll notice that for  you see a signal with twice the input frequency. In fact, semiconductor mixers are usually based on that principle, and thus are basically amplifiers driven out of spec :)



On 04/23/2015 01:07 AM, Paul B via USRP-users wrote:

  Hi guys, 

  My troubles seem to be at no end at the moment!


  After reinstalling my Windows 8.1 due to a hard drive change, i've been having trouble with my B200 on HDSDR using Balints ExtIO_USRP+FCD+RTL2832U + BorIP-1.6 BETA 3. 

  Before re-installing Windows 8.1, i had no issues at all, but since re-installing, i've been getting  what seem like ghost signals on airband. They appear from about 114MHz through to 128MHz. They appear to be broadcast FM, Trunking and MotoTRBO signals, though when i move the frequency slider, they vanish, only to reappear when i move further along the band.

  I've included a picture of the problem, and my settings in ExtIO:

  https://www.dropbox.com/s/o6u3oe83ch4gm9o/Signals.jpg?dl=0

  and my settings:

  https://www.dropbox.com/s/082d17pi0osnw36/Settings.jpg?dl=0

  I'm running the B200 over USB 3, and it's using 003.007.001, which unfortunately, i can't seem to upgrade due to getting an incompatability warning when trying to use HDSDR after upgrading. 
  I've installed the B200 USB Driver, and in Device Manager, my device shows up as USRP B200. 

  Does anyone have any idea what could be causing this problem, and any possible solution?

  Thanks for any help,

  Paul


   

_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com




--------------------------------------------------------------------------------
_______________________________________________
USRP-users mailing list
USRP-users at lists.ettus.com
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150423/0660a5f0/attachment-0002.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: tblatex-4.png
Type: image/png
Size: 1117 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150423/0660a5f0/attachment.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: tblatex-3.png
Type: image/png
Size: 1367 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150423/0660a5f0/attachment-0001.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: tblatex-2.png
Type: image/png
Size: 1828 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150423/0660a5f0/attachment-0002.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: tblatex-1.png
Type: image/png
Size: 1262 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150423/0660a5f0/attachment-0003.png>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: tblatex-5.png
Type: image/png
Size: 2400 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150423/0660a5f0/attachment-0004.png>


More information about the USRP-users mailing list