[USRP-users] Can't Find USRP N200

Martin Braun martin.braun at ettus.com
Wed Apr 22 19:43:19 EDT 2015


Carlos,

On 22.04.2015 16:29, Carlos Quiroga via USRP-users wrote:
> I am new using the USRP's, i have an USRP N200 and I have installed the
> GNU radio "|gnuradio-3.6.0.||tar||.gz|" and the UHD
> "uhd_003.005.001-49-stable_Ubuntu-12.04-x86_64.deb"  but I can't find my
> USRP when I run command uhd_usrp_probe --args="addr=192.168.10.2". I
> have set my host Ethernet interface (Fast Ethernet) with a static IP
> address (192.168.10.1).

Two quick things to look into:
- That UHD + GNU Radio versions are very, very old. It should work, but
I recommend upgrading.
- uhd_find_devices and uhd_usrp_probe don't require you to know the
USRP's IP, as long as it's on the same subnet. So try without the
--args. If you're sure about the IP, try ping.

> I have been trying load the images onto the On-board Flash for N series
> but I don't know what is the difference between the binaries too:
> 
> -usrp_n200_r2_fpga.bin 
> -usrp_n200_r3_fpga.bin 
> -usrp_n200_r4_fpga.bin 

Different revisions (rev 2, rev 3, etc.). Your board revision should be
on the silkscreen, if in doubt. But the revision is also stored in the
EEPROM, and should correctly be detected.

> in other hand when I tried to install the UHD version 003.008.003 I had
> some problems to install it, that is the reason because I installed  UHD
> 003.005.001

Which problems did you have? Which OS are you using?

> Any ideas on what might be preventing the USRP N200 from being
> identified by the host PC?
> 
> Is the Fast Ethernet a problem in my host? (it suppose when I connect my
> USRP with my laptop the Ethernet green led are on, but in my case those
> are always off, and the B and F led are on)

You can find the description of the LEDs at
http://files.ettus.com/manual/page_usrp2.html#usrp2_hw_leds. You need a
1GBit connection.

Cheers,
Martin
> 
> whats the meaning of those binaries?
> 
> All advice is very apreciated, Thanks






More information about the USRP-users mailing list