[USRP-users] Cannot find usrp e310 with uhd_find_devices

Marcus Müller marcus.mueller at ettus.com
Tue Apr 21 12:44:59 EDT 2015


Dear Ivan,

the E310 is not designed to work as a peripheral to a PC, but is its own
embedded computer, integrating a USRP. You'd normally run your signal
processing applications, for example GNU Radio, on the E310 itself
rather than on a separate PC.
Thus, E310 can't be detected by uhd_find_devices.

You can try the network_mode [1] on the E310, but it's really just a
diagnostic tool, and delivers only very small sampling rates.

Best regards,
Marcus Müller

[1] http://files.ettus.com/manual/page_usrp_e3x0.html#e3x0_network_mode
On 04/21/2015 07:44 AM, Ivan via USRP-users wrote:
> Hi,
>
> I've recently started using an E310 USRP. I want to use some GNU radio
> examples to generate and receive waveforms but the device is not being
> detected. I can log on using both the console and ethernet port. I've
> configured the usrp to use a static IP address and set it to
> 192.168.10.3. I can access this address through ssh and pinging it
> also sends replies back. However, running uhd_find_devices does not
> work. I get "no uhd devices found". Even when I specify the address
> with uhd_find_devices --args="addr=192.168.10.3", I still don't get
> anything. 
>
> I use Ubuntu 14.04. I've installed gnuradio and uhd using the gnuradio
> build script. When I run uhd_find_devices or uhd_fft, the uhd version
> that comes out is UHD_003.008.003-137-g2f760ac0. I've also tried
> disabling the firewall with sudo ufw disable, but that makes no
> difference. What else should I do?
>
> Regards,
> Ivan
>  
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150421/09a3d013/attachment-0002.html>


More information about the USRP-users mailing list