[USRP-users] time sync 2 ettus x310

Sanjoy Basak sanjoybasak14 at gmail.com
Tue Apr 21 04:34:54 EDT 2015


Dear Mr. Martin,
Thanks for the reply. Yes, right now I am not using octoclock, so the
problem while using 2 USRPsis understandable.

However, regarding distortion, yes I am having distortion at the beginning
when I am using one usrp  for SISO case for x310. I found this problem even
in b210 as well. I wonder why no one discussed or how did they actually
solved for radar uses. But I hope I would get my solution here.


[image: Inline image 1]
This is a figure of xcorr of rx and tx signal. The red marked distortion I
am having almost always. I don't know the reason. If I drop few bins in my
binary file and then start receiving my signal then I am getting an
undistorted signal looks like the following.( I am transmitting and
receiving using binary file).
However, dropping bins is undesirable for radar application.
[image: Inline image 3]
If I use the distorted frame, as obvious I get distorted result. However,
after dropping bins the fresh frame gives me the exact result after signal
processing in matlab.
Can you please tell me how to avoid this distortion at the beginning?

best regards
Sanjoy








On Tue, Apr 21, 2015 at 12:10 AM, Martin Braun via USRP-users <
usrp-users at lists.ettus.com> wrote:

> Sanjoy,
>
> if you want to do radar, you need to make sure both devices are
> connected to the same external reference. For radar, you can't run off
> of separate clocks.
>
> We've confirmed timing accuracy across devices on the nanosecond scale
> in the past (using OctoClocks for clock distribution).
>
> Cheers,
> M
>
> On 17.04.2015 06:00, Sanjoy Basak via USRP-users wrote:
> > Hi all,
> > I am trying to sync 2 ettus x310 in time. However, I am always having a
> > distortion at the beginning after receiving, and there is always a
> > delay of few microseconds between the tx and rx. I put tx in one x310
> > and rx in another x310 and its in a wired connection. GPS antenna is
> > connected to one usrp(with Tx) and another one is on external ref(Rx).
> >
> > So now if I check the last pps on both usrp; it shows tx:0; rx:2s;
> > then I am compensating it making it set_start_time both at for 4s. So
> > ideally I should get time synced tx and rx signal.
> >
> > But I am getting distortion in Rx signal for 2seconds at the beginning;
> > this is constant for every sampling freq; so if in that region I have my
> > rx signal I can't retrieve that as the distortion is already introduced
> > there.
> > As I am trying to implement radar with x310, this is a serious problem
> > for me. As within first 2 seconds and few microseconds I can't receive
> > anything.
> >
> > I would really appreciate any kind of suggestion that come through. If
> > anyone have question regarding setup or python code please ask.
> > Thanks for reading.
> >
> > Best regards
> > Sanjoy
> >
> >
> >
> > _______________________________________________
> > USRP-users mailing list
> > USRP-users at lists.ettus.com
> > http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
> >
>
>
> _______________________________________________
> USRP-users mailing list
> USRP-users at lists.ettus.com
> http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150421/9d3079fc/attachment-0002.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: untitled2.jpg
Type: image/jpeg
Size: 18723 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150421/9d3079fc/attachment.jpg>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: untitled.jpg
Type: image/jpeg
Size: 122891 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150421/9d3079fc/attachment-0001.jpg>


More information about the USRP-users mailing list