[USRP-users] about time sync of 2 x310

Sanjoy Basak sanjoybasak14 at gmail.com
Fri Apr 17 15:00:31 EDT 2015


I am trying to sync 2 ettus x310 in time. However, I am always having a
distortion at the beginning after receiving, and there is always a delay
of few microseconds between the tx and rx. I put tx in one x310 and rx
in another x310 and its in a wired connection. GPS antenna is connected
to one usrp(with Tx) and another one is on external ref(Rx).

So now if I check the last pps on both usrp; it shows tx:0; rx:2s;
then I am compensating it making it set_start_time both at for 4s. So
ideally I should get time synced tx and rx signal.

But I am getting distortion in Rx signal for 2seconds at the beginning;
this is constant for every sampling freq; so if in that region I have my
rx signal I can't retrieve that as the distortion is already introduced
there.
I am using binary file for transmitting and also for receiving and doing
processing in matlab.

As I am trying to implement radar with x310, this is a serious problem
for me. As within first 2 seconds and few microseconds I can't receive
anything.

I would really appreciate any kind of suggestion that come through. If
you have any question regarding setup or python code please ask.
Thanks for reading.

best regards
Sanjoy
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150417/8d25f80c/attachment-0002.html>


More information about the USRP-users mailing list