[USRP-users] [Discuss-gnuradio] New UHD seems to break a lot...

Ralph A. Schmid, dk5ras ralph at schmid.xxx
Fri Apr 17 14:48:54 EDT 2015


I have put it all here, flow graphs and screenshots of the flow graphs:

http://dk5ras.dyndns.org/tmp/DVB/

This way we can keep it on the list without sending attachments.

They were taken from the VM container before all the upgrades were made, but
I did not change anything when upgrading.

Ralph.



-----Original Message-----
From: Ian Buckley [mailto:ianb at ionconcepts.com] 
Sent: Friday, April 17, 2015 19:25
To: Ralph A. Schmid, dk5ras
Cc: 'Martin Braun'; usrp-users at lists.ettus.com; 'GNU Radio Discussion List'
Subject: Re: [Discuss-gnuradio] New UHD seems to break a lot...

Great Ralph, thats a big help. Can you send me your exact flow graph used to
generate these 2 plots off list please. I want to re run this scenario and
see your exact configuration.

Thanks
-Ian

On Apr 17, 2015, at 10:00 AM, "Ralph A. Schmid, dk5ras" <ralph at schmid.xxx>
wrote:

> OK, here we go. The hotel TV was dvb-c only, so I had to do the tests 
> back at home.
> 
> I took my perfectly working Kubuntu 14.04 64 bit VM container together 
> with my B210, made a copy and updated this one, first I made a git 
> pull to get latest master, built it, rebuilt gnuradio, rebuilt 
> gr-dvbt, updated the FPGA images, and everything still was fine. The
chosen dvb-t bandwidth is 8 MHz.
> 
> Then I changed to 003_008_003_rc1, did the same procedure, fired up 
> grc, and the signal was not decodable both with a dvb-t PC receiver 
> and with an dvb-x analyzer. The analyzer saw the RF level, but no 
> data, no constellation, nothing, it looked to him like interference.
> 
> When you have a look at the two "uhd" screenshots here 
> http://dk5ras.dyndns.org/tmp/DVB/ made with my spectrum analyzer then 
> you will find that RC1 produces a somehow narrower signal, so it 
> really looks something gets cut at the ends with all the filtering and DSP
stuff.
> Adjusting the channel bandwidth in the uhd sink block from 0 to a 
> sensible value changes nothing.
> 
> Btw., the dvb-t2 package behaves identical.
> 
> Ralph.
> 
> 
> -----Original Message-----
> From: Martin Braun [mailto:martin.braun at ettus.com]
> Sent: Wednesday, April 15, 2015 21:14
> To: Ralph A. Schmid, dk5ras; usrp-users at lists.ettus.com; 'GNU Radio 
> Discussion List'
> Subject: Re: [Discuss-gnuradio] New UHD seems to break a lot...
> 
> master works, but RC1 does not? Huh, I'm confused now. Can you give 
> some detail on what's going on, so we can try and reproduce this?
> 
> Thanks,
> Martin
> 
> On 15.04.2015 12:52, Ralph A. Schmid, dk5ras wrote:
>> RC1, master seems to work.
>> 
>> Ralph.
>> 
>> -----Original Message-----
>> From: Martin Braun [mailto:martin.braun at ettus.com]
>> Sent: Wednesday, April 15, 2015 15:44
>> To: Ralph A. Schmid, dk5ras; usrp-users at lists.ettus.com; 'GNU Radio 
>> Discussion List'
>> Subject: Re: [Discuss-gnuradio] New UHD seems to break a lot...
>> 
>> Thanks, Ralph. Just to clarify: When you say 'New UHD', do you mean 
>> 3.8.3-RC1, or latest master?
>> 
>> Martin
>> 
>> On 15.04.2015 08:40, Ralph A. Schmid, dk5ras wrote:
>>> It is a B210, but as a note, due to the up to now missing FPGA 
>>> images I used 003.008.003-RC1, not the latest master. Still I had no 
>>> access to a spectrum and DVB-T analyzer, so I have no idea what is 
>>> happening, I just can confirm that RF is transmitted, and the 
>>> receiver doesn't get a picture, while with the snapshot of the same 
>>> VM before the upgrade
>> is received without problems.
>>> I will know more in about three hours.
>>> 
>>> Ralph.
>>> 
>>>> -----Original Message-----
>>>> From: Martin Braun [mailto:martin.braun at ettus.com]
>>>> Sent: Wednesday, April 15, 2015 3:15 PM
>>>> To: Ralph A. Schmid, dk5ras; usrp-users at lists.ettus.com; 'GNU Radio 
>>>> Discussion List'
>>>> Subject: Re: [Discuss-gnuradio] New UHD seems to break a lot...
>>>> 
>>>> On 15.04.2015 06:20, Ralph A. Schmid, dk5ras wrote:
>>>>> Hi,
>>>>> 
>>>>> Not only OpenBTS is affected, also gr-dvbt/t2 do not work any more 
>>>>> with latest uhd. A quick check during lunch break showed, the 
>>>>> produced output is not decodable any more. I will take a closer 
>>>>> look this evening at home, where I have more and better equipment.
>>>> 
>>>> Ralph,
>>>> 
>>>> which device is this on?
>>>> 
>>>> Thanks,
>>>> Martin
>>> 
>> 
>> 
> 
> 


-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 832 bytes
Desc: not available
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150417/6e62b39d/attachment.sig>


More information about the USRP-users mailing list