[USRP-users] Error "fifo ctrl timed out looking for acks"

Marcus D. Leech mleech at ripnet.com
Fri Apr 10 11:58:09 EDT 2015


On 04/10/2015 11:34 AM, Jonathan Verlant-Chenet wrote:
> Hi Marcus,
>
> Thanks for your answer.
>
> Both computer I tested are using the same switch and the same network 
> interface (/Qualcomm Atheros AR8161/8165 PCI-E Gigabit Ethernet 
> Controller (NDIS 6.20)/). But one computer never shows that error. Is 
> it possible that the problem is due to something else?
>
> Jonathan
>
Make sure they're running the same version of UHD.

Are they running the same operating system?

Have you tried swapping cables?

Do both computers have similar firewall rules?


>
> On Fri, Apr 10, 2015 at 6:52 AM, Marcus D. Leech via USRP-users 
> <usrp-users at lists.ettus.com <mailto:usrp-users at lists.ettus.com>> wrote:
>
>     On 04/10/2015 12:47 AM, Jonathan Verlant-Chenet via USRP-users wrote:
>
>         Hi,
>
>         I'm using 3 USRP N210 R4 controlled by one computer through a
>         gigabit
>         Ethernet switch and Cat 6 Ethernet cables. The USRPs are commanded
>         through a c++ script lauched by a Matlab code. The host runs on
>         Windows with Matlab 2013a, VS2010 and UHD 003.008.000 (same
>         version on
>         the device)
>
>         I'm getting the error "fifo ctrl timed out looking for acks"
>         whatever
>         the parameters I put, something like 9 times out of 10 tries.
>         I read
>         online that the "link" between the host and the devices might
>         be down.
>         So I tried rebooting every part the equipment, or simplifying
>         it to 1
>         Ethernet cable between 1 host and 1 USRP. The result is the same.
>
>         When I try with another computer (same model, but only matlab
>         and the
>         UHD drivers are installed), the error does not appear.
>
>         Can you help me identifying the source of this error?
>
>         Thanks in advance,
>         Jonathan
>
>         _______________________________________________
>         USRP-users mailing list
>         USRP-users at lists.ettus.com <mailto:USRP-users at lists.ettus.com>
>         http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>     It's likely that your gigabit switch is dropping traffic, or you
>     have a Intel 82579LM-based network interface on your host machine
>     which is
>       dropping traffic.
>
>
>
>     _______________________________________________
>     USRP-users mailing list
>     USRP-users at lists.ettus.com <mailto:USRP-users at lists.ettus.com>
>     http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150410/927f2351/attachment-0002.html>


More information about the USRP-users mailing list