[USRP-users] USRP E310. Update UHD on SD card to latest version

Paul Harbanau paval.volny at gmail.com
Tue Apr 7 05:17:27 EDT 2015


Greetings to all!

I have a problem with the communicating with E310. I can run a preinstalled
to SD card examples. But when I tried to run the examples on my host
machine (with  --args="addr=..."), I got the error FPGA compatibility.
The problem was solved after running uhd_images_downloader on E310 device.
But now the version of the library is not compatible with FPGA images. So i
need help to update UHD to the latest version (003.008.002).

I tried to make checkout and cmake (on E310). But it gives an error:

# cmake -DCMAKE_TOOLCHAIN_FILE = .. / cmake / Toolchains /
arm_cortex_a8_native.cmake -DENABLE_E100 = ON -DENABLE_USRP_E_UTILS = TRUE
../

*...*
*The C ++ compiler "/ usr / bin / g ++" is not able to compile a simple
test*
*  program*
*...*

Then I tried to install OpenEmbedded SDK on the host computer and cross
compile for E310. Then copy this UHD build to the SD card.
But the example programs doesn't see libs like boost.

root @ ettus-e300: /usr/lib/uhd/examples # ldd benchmark_rate
./benchmark_rate: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.20 'not
found (required by ./benchmark_rate)
./benchmark_rate: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.20 'not
found (required by /usr/lib/libuhd.so.003)
        libuhd.so.003 => /usr/lib/libuhd.so.003 (0xb6a08000)
        libboost_program_options.so.1.57.0 => not found
        libboost_system.so.1.57.0 => not found
        libboost_thread.so.1.57.0 => not found
        libpthread.so.0 => /lib/libpthread.so.0 (0xb69e8000)
        libstdc ++. so.6 => /usr/lib/libstdc++.so.6 (0xb691c000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb68f7000)
        libc.so.6 => /lib/libc.so.6 (0xb67c0000)
        libboost_date_time.so.1.57.0 => not found
        libboost_filesystem.so.1.57.0 => not found
        libboost_regex.so.1.57.0 => not found
        libboost_system.so.1.57.0 => not found
        libboost_thread.so.1.57.0 => not found
        libboost_serialization.so.1.57.0 => not found
        librt.so.1 => /lib/librt.so.1 (0xb67b1000)
        liborc-0.4.so.0 => /usr/lib/liborc-0.4.so.0 (0xb6741000)
        libusb-1.0.so.0 => /lib/libusb-1.0.so.0 (0xb672d000)
        libudev.so.0 => /lib/libudev.so.0 (0xb671a000)
        libdl.so.2 => /lib/libdl.so.2 (0xb670f000)
        libm.so.6 => /lib/libm.so.6 (0xb669e000)
        /lib/ld-linux-armhf.so.3 (0xb6f3d000)

Please help, how can I update UHD on SD card?


Best Regards,
Paul
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ettus.com/pipermail/usrp-users_lists.ettus.com/attachments/20150407/80f045ef/attachment-0002.html>


More information about the USRP-users mailing list